Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I sometimes see weird characters on some websites instead of what they're meant to display. I've attached an image below as an example. In IE the site displays correctly but on Chrome there are weird characters instead.

My encoding settings on Chrome are set to Auto detect/Unicode UTF-8. I've tried reinstalling all my Windows default fonts too but no success.

Does anyone have a fix for this? Most solutions I've looked at haven't been successful

enter image description here

share|improve this question
    
Since you mentioned it: What solutions have you tried? –  slhck Apr 3 '12 at 12:19
    
Reinstalling fonts (which was a solution I found here, trying different encoding settings, reinstalling Chrome, The encoding one seems to be the most common solution I've come across –  Flynn Apr 3 '12 at 12:56

4 Answers 4

You can solve this problem by following these easy steps:

  1. Go to Settings.
  2. Click Show advanced settings.
  3. Under Web content next to Font size click Customize font and choose Times New Roman.
share|improve this answer

If the above solution did not work (my case) I have a solution that should work for everyone.

To fix this simply install "Font Changer with Google Web Fonts" and you should be good to go! Only down side is that know every font is the same, but it's still better than seeing "HV%/(Viun&#okIUYGy8765&%$" and guessing that it means "Next".

share|improve this answer
up vote 6 down vote accepted

I've found the solution. I had a couple of corrupted/bad Helvetica fonts so I got rid of all of those and found some fresh new ones. Problem solved.

share|improve this answer

Probably an encoding problem. It's not unique to Chrome, either: I see it all the time in Firefox. Try a different encoding (In chrome, click the wrench>Tools>Encoding). Western will probably fix it.

share|improve this answer
    
Thanks, that seemed to have fixed it. Strangely enough when I un-did the change, it was still fixed. Maybe it had something to do with a recent Chrome update. Anyways problem solved :) –  Flynn May 18 '12 at 7:32
    
Different encodings mess up with unusual Unicode characters; that fix is broken form start. –  JMCF125 Dec 27 '13 at 11:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.