Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes my PC wakes up (from sleep mode) without any visible reason. Wake-on-LAN is turned off. Vista 64 bit SP2
Any ideas?

share|improve this question
    
The same thing happened to me. I suspect the PSU had something to do with it... –  alex Sep 14 '09 at 6:40
3  
give it some warm milk, and sing it a lullaby ;) –  Nick Josevski Sep 14 '09 at 6:47
add comment

5 Answers

In an elevated command prompt, run the command "powercfg -energy". It will run for a minute and produce a report of the power configuration of your computer, including all events that can bring it out of sleep mode.

Also in an elevated command prompt, run "powercfg -lastwake". It should tell you which event or device brought it out of sleep mode the last time.

share|improve this answer
    
"powercfg -energy" - says Invalid Parameters :-/ "powercfg -lastwake" - says "Wake Source Count - 0". Something completely meaningless. –  skevar7 Sep 14 '09 at 6:49
    
Oups, "-energy" is Windows 7 only. But the other one "-lastwake" is supported in Vista. –  Snark Sep 14 '09 at 6:59
    
It doesn't help anyway. See above. Any ideas why it shows such strange message? –  skevar7 Sep 14 '09 at 7:29
add comment
  1. Click Start, right click Computer and choose Properties.
  2. Click Device Manager.
  3. Navigate to your network adapter, right click it and choose Properties.
  4. Choose Power Management tab.
  5. Please uncheck “Allow this device to wake the computer”
  6. Restart the computer and test this issue again.

[EDIT]

(check for other devices too who had that option enabled)

share|improve this answer
    
What "this" device? :-/ –  skevar7 Sep 14 '09 at 6:55
    
the network adapter ... –  Revolter Sep 14 '09 at 6:58
    
Already unchecked :-/ –  skevar7 Sep 14 '09 at 7:02
    
Do you have more than one network adapter listed? –  ChristianLinnell Sep 14 '09 at 7:10
    
Who marked this down? It's a perfectly valid explanation to this problem, even if it doesn't solve this particular case. +1 –  ChristianLinnell Sep 14 '09 at 7:22
show 1 more comment

Do you have any bluetooth devices paired and active while the machine is asleep? My bluetooth mouse will wake my computer from time to time.

share|improve this answer
    
I have a bluetooth mouse. Any additional info on this problem? –  skevar7 Sep 14 '09 at 11:14
    
Might want to re-install the driver. –  D'Arvit Sep 15 '09 at 15:13
    
I use a Macbook, so not sure about Vista, but if I leave my bluetooth mouse switched on, the slightest movement will try to wake the thing. The problem goes away if I switch the mouse off. –  Olly Hodgson Sep 16 '09 at 12:35
add comment

I once had two PCs in one room. One was setup (in BIOS) to start on left mouse klick. That PC started completely randomly. After a few days I noticed it was the mouse. Both PCs had wireless mice, and for some reason, both mice were setup for the same channel. So the 2nd PC started, when I clicked the mouse button on my PC.

Maybe its a similar problem with your setup?

share|improve this answer
add comment
up vote 0 down vote accepted

It was a problem with the mouse. Sometimes optical mice generate fake "move" events, even though mouse doesn't move actually. Disabling waking up by mouse solved this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.