Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to VirtualBox and am trying to set up an instance of Windows 7 64.

I have the virtual machine instance running with Windows 7 now installed, but it only fills up a small portion of my screen. Even when I go full screen, the window stays the same size and the rest of the screen is filled with gray space.

I have installed VirtualBox Guest Additions, which allowed me to go from a resolution of 800x600 to 1024x768, but this still isn't satisfactory as my laptop display is 1600x900.

Any help on this would be most appreciated. Thanks.

share|improve this question
    
can you post a screenshot with VB at fullscreen mode? – Sathya Apr 3 '12 at 16:45
    
I'm having a similar problem, though it cropped up out of nowhere after things had worked properly for about 2 years. Mountain Lion host, XP guest, VBox v4.2.6. I increased the VM's total memory and video memory to no avail. – psoft Feb 6 '13 at 4:35
    
Just figured it out for myself - see answer. – psoft Feb 6 '13 at 4:42

You must install guest additions. In the "Devices" menu in the virtual machine's menu bar, VirtualBox has a handy menu item named "Install guest additions", which mounts the Guest Additions ISO file inside your virtual machine. A Windows guest should then automatically start the Guest Additions installer, which installs the Guest Additions into your Windows guest. After that your virtual OS scren will be automatically change resolution to fill entire screen.

share|improve this answer
2  
For my case I found this answer not explicit enough. For OSs: MAC OS(host), Win(guest): 1.Applications > right-click VBox.app > locate VBoxGuestAdditions.iso 2.In VirtualBoxManager > Storage > drag&drop .iso file here. 3.In the host machine menu Devices > Optical Drives > select .iso file. Then open cd drive in Windows and install guest editions with double-click on .exe file. Finally, reboot. – boldnik Jan 27 at 20:51

Try increasing the virtual graphics adapter's memory to 64 or 128M. That might help. You may also want to see if you can change the screen resolution from within the guest OS.

share|improve this answer
1  
This did it for me. It defaulted to 27MB – Basic Jan 7 '15 at 12:26

Auto-resize Guest Display

After leaving the comment on your original question, I figured out my problem. I had hit Command-G instead of Command-F. On Mac host, Command-G toggles an "Auto-resize Guest Display" setting. That fixed it.

share|improve this answer
    
All that does is take you to full screen. – Jayden Lawson May 27 '14 at 13:27

There is a menu option in VirtualBox GUI under Screen > Go to full screen; also accessible through Host + F by default. (you can configure the host key in VBox options).

During a fullscreen session you should have a hidden bar on the bottom of the screen with restore tools: just tap the bottom of the screen with the mouse pointer.

share|improve this answer
1  
Yes, I understand that, but what I'm trying to say is that once it is in full screen, the viewable portion of the virtual machine OS is still set to 1024x768 and all although the VirtualBox program is filling the whole screen, everything around the OS window at 1024x768 is just filled with gray. So I can't make the screen fill my entire display. – jdavis Apr 3 '12 at 16:33
    
Sorry, I understood the question wrong: see my other answer – PPC Apr 3 '12 at 18:27

There might be three causes as far as I know:

  • Either your video card doesn't support such high resolution: as BobTsaid you can try tuning your video card settings in the VM properties
  • Or it may be that the resize event is not interpreted correctly by VirtualBox: what happens if you resize the window by dragNDropping the corner to a resolution higher than 1027*768? If this works (allowing you to go higher than that), then you should try entering and leaving full screen several times
  • And if you are using an application that takes full control of the screen (eg. a game), and that application doesn't support your target resolution, then not much can be done.
share|improve this answer

You need to reboot VM after installing guest additions, and then select options to auto-resize guest display etc to your liking.

share|improve this answer

I had the same problem and my Guest Addition was installed correctly. I read BobT suggestion above and checked my adapter graphic memory and it was using 128 MB. I changed it to 256 MB and everything got fixed. Then changed it back to 128 MB and now everything is fine :)
So maybe just a change is need to hint VB graphic adapter.
Hope it works :)

share|improve this answer

protected by Community Sep 15 '14 at 22:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.