Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got Firefox 11 running in Windows 7, and the 3D DOM viewer doesn't appear for me; it's not an option in the Developer Tools. I know where to look, because I've used it on another computer under OS X. Do I have to change a setting somewhere to enable it?

EDIT: The solution ended up being updated graphics drivers. I'm on a 17" MacBook Pro with an NVIDIA GeForce GT 330M.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

3D View requires WebGL. Your graphics card may be blacklisted by Firefox or your graphics card drivers are outdated. If updating your drivers does not resolve the issue, you can force-enable unsupported features by setting the following preferences under about:config:

  • WebGL - webgl.force-enabled = true

  • WebGL anti-aliasing - webgl.msaa-force = true

  • Layers Acceleration - layers.acceleration.force-enabled = true

  • Direct2D Content Acceleration - gfx.direct2d.force-enabled = true

share|improve this answer
    
I set these to true and restarted Firefox and I still don't have the 3D DOM option. –  Mr. Jefferson Apr 4 '12 at 16:28
    
Then, your graphics card is likely not compatible. –  iglvzx Apr 4 '12 at 19:58
    
I went and updated my graphics drivers and restarted Firefox, and it worked. –  Mr. Jefferson Apr 4 '12 at 21:11
    
I see. I assumed you already tried updating your drivers, as I mentioned in my answer! :) –  iglvzx Apr 4 '12 at 21:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.