Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I made have an image that was made on a Dell computer. This Dell had "RAID mode" set in the bios. If I load and then boot the image on any other computer set to AHCI or AHCI/RAID, I get BSOD. Same happens in Virtualbox.

On a physical machine, I can just go to the bios and switch it. How can I do this in Virtualbox?

share|improve this question
    
Hi! I'm having the same exact issue. Did you ever find a way to resolve it? –  Francisco Zarabozo May 28 at 18:44
    
I think just changing a setting. I don't remember which one though. Found helpful info here: virtualbox.org/manual/ch03.html#settings-motherboard –  Matt May 29 at 18:55

2 Answers 2

You need to install the AHCI driver for the operating system before you switch it in the BIOS. You can do this from Device Manager by updating the IDE bus device driver to the revelant AHCI bus driver for your computer.

share|improve this answer

Add the virtual disk to the Virtualbox VM as an IDE drive and set the IDE controller type to ICH6.

Virtualbox IDE Controller type

share|improve this answer
    
Didn't work, what does this actually (virtually) change when you select ICH6? –  Matt Apr 4 '12 at 21:03
1  
PIIX4 and ICH6 are different IDE drive controller chipset technologies. Please update your question with BIOS version and hard drive controller Make/Model of the RAID hardware controller on the physical computer. It may be that adding a SCSI controller to VB is the right answer. –  Jeremy W Apr 6 '12 at 19:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.