Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Strange question... Occasionally, on my LCD screen, pixels that should be black flicker rapidly and constantly between black and green, about 4 flickers a second.

The crazy part is, unlike dead/stuck pixels, they are relative to content on the screen and move with it.

For example, I might be looking at a web page with a picture that has lots of black. There might be a couple of green flashing pixels in that black that shouldn't be there. I scroll the page, and the green flickering pixels move with the image. It seems that everyphysical pixel is fine, but somehow something interprets part of the image in a way that causes flickering green...

It's not just in a web browser. My first thought was to blame a trolling blogger cunningly uploading an animated gif that simulates a failing pixel... but it happens in a wide range of applications. It seems to occur randomly, other than that it seems to only occur in areas of pure black, and it's always pure 100% green.

It happens rarely enough that it's not a big deal, but it's such a strange problem it bugs me. I can't find any info on anything like this. I'm not even sure if it's hardware or software.

Any ideas? (windows 7 laptop connected to LCD by DVI to HDMI cable)

share|improve this question
6  
This sounds to me like it might be a video RAM problem, but I've never seen anything that's behaved quite like this. –  Shinrai Apr 3 '12 at 22:25
2  
I've seen a similar problem using a G5 Powermac driving a Cinema display. Shapes on screen develop odd green borders. Turning off the monitor briefly and back on again cures the problem. It's happened only a few times in the seven years I've had the gear. I agree with @Shinrai -- video memory corruption seems the best fit for the symptoms. –  Kyle Jones Apr 3 '12 at 23:14
    
Sounds like a good theory. It's an old laptop running a hefty HD screen and a VGA screen at the same time - could it be a symptom of overloaded video RAM? –  user568458 Apr 3 '12 at 23:37
2  
I wouldn't say 'overloaded', per se (either it's in use or it isn't) but possibly it's getting too warm or something like that. The only remedy probably would be replacing the laptop and I doubt it's worth bothering. I'm still not 100% convinced (or this would be an answer instead of a comment) but I just can't think of any other explanation right now. –  Shinrai Apr 3 '12 at 23:49
1  
For others who are experiencing similar problems: apart from broken VRAM and overheating, these video memory corruption symptoms have also been associated with the card experiencing drops in voltage. So if that's something you haven't checked yet, it might be your PSU that's giving out. –  Daniel Saner Jul 21 '12 at 4:25

6 Answers 6

up vote 6 down vote accepted

TLDR: My fix was using a much shorter and better quality cable.

I managed to find a solution to this not that long ago on a brand new monitor that required me to buy a cheap 5m DVI to HDMI cable (I couldn't get anything else quickly).

Like you the problem was highly dependant on what was on screen and seemed more prevalent with darker images. When moving windows around they seemed to "push" the flickering pixels around which I found aggravating.

I tried a number of things including changing screen resolution, refresh rate, colour space (sRGB/CMYK as my graphics card supported both) and nothing at all would stop the flickering pixels.

Eventually in frustration I purchased a simple DVI to HDMI adaptor and combined with a 1.5m HDMI cable and appeared to fix the problem for me. I can only assume that due to the age of my graphics card and the questionable nature of the long cable that data signals for darker areas were somehow corrupted, perhaps something about weak signals and the 8/10b encoding. I'm not completely sure why, but this completely got rid of my flickering pixels.

-=EDIT=-

I've tried to look into what might have been causing this issue for me and so here's my disclaimer for the next bit: Here be dragons and wild guesses as to what is failing.

DVI (and HDMI) use TMDS. TDMS, according to wikipedia, uses "current mode logic (CML), DC coupled and terminated to 3.3 Volts" The effective signal path between transmitter and receiver looks something like this:

enter image description here

My wild guess is that due to the DC coupling at the destination the source must effectively "sink" the current out of the wire in order to produce a valid "0" on the line. A longer (and lower quality) cable will have a higer resistance and thus mean that the source must work marginally harder to pull the line low.

This is where my "weak graphics card" hypothesis comes into play. If the source is unable to completely and consistantly sink the current in the wire then by the time the destination is reading the bit pattern it may be that it reads a 1 where there should be a 0, causing a bit error. Too many bit errors lead to a pixel error and thus the pixel gets the wrong value and appears to be the wrong colour. Now the kicker is that these errors will not be completely consistant due to the source sometimes managing the job and sometimes failing.

I have a suspicion that the somewhat non-random nature of the problem is somehow also related to the 8/10b encoding which tries to achieve DC balance in the signalling protocol. My flickering was worse in particular areas, with there seeming to be some correlation between a group of dark and light mixtures making a "flicker" more likely to happen. I do not understand enough about it to form a firm idea of why it might cause the problem.

Of course, it could have just been a dodgy connector in the cable (I tried both graphics card outputs so nada there...)

share|improve this answer
    
Sounds likely: my setup also involves an excess of basic quality cabling. If a fix worked for you I imagine it might work for me: I'm not in a position to test (long story) but this sounds right. I'm surprised since digital signals are by definition binary, but I guess the problem is essentially binary... –  user568458 Jun 25 '12 at 11:19
    
I had a similar problem after getting a new PC at work. The monitor worked fine with the old one, but the new one had a DisplayPort output, so I had to get DP->DVI adapter. Tried two different adapters, and switching cables, and neither made the problem go away. Dell said it was the monitor, even though it worked fine with the old computer, so I just ended up getting a new monitor to fix the problem. Your explanation seems to fit what I saw. The new computer must have been slightly weaker and the new monitor is also weaker so the new pc can pull it down. –  psusi Jun 25 '12 at 15:43

Late to the party, but it may prove useful: ( http://www.overclock.net/t/692956/just-got-rid-of-green-dots-on-screen )

The problem is simply because ATI drivers set 2D clocks too low (157Mhz Core,300Mhz memory). At higher resolutions like 1680x1050 these clocks are not sufficient and causes this problem so you need to up them to get rid of these green dots randomly appearing on the screen.

I found this post in AMD official forums. Follow the instructions, it's very simple:

Code: Hey guys,

I did the same and it helped a little bit but there were some green pixels left so I created a CCC-Profile and modified the xml-profile file via the editor and changed the idle clock from 157/300 to 300/500. Now there are no green pixels left and I think I can live with this solution.

To modify the CCC profile you have to do as follows:

  1. Open CCC
  2. Unlock and Enable Overdrive if they aren’t already.
  3. Go to Options/Profiles/Profiles Manager. Create a new profile. Under composition make sure “ATI Overdrive” is checked. Save and Close, DO NOT ACTIVATE.
  4. In windows go to: C:\\Users\\{yourusername}\\AppData\\Local\\ATI\\ACE\\Prof iles (you will need to have “show hidden files” turned on for this)
  5. Open the xml document with the name of the profile you just created (notepad is fine)
  6. Change the values of the Clock and Memory speeds to look like this (these specific values are what worked for me and my card, use judgment) EDIT ONLY THE BOLD VALUES.

    Feature name="CoreClockTarget_0"

    Property name="Want_0" value="30000"

    Property name="Want_1" value="60000"

    Property name="Want_2" value="85000" Feature Feature name="MemoryClockTarget_0"

    Property name="Want_0" value="50000"

    Property name="Want_1" value="90000"

    Property name="Want_2" value="120000"

  7. Save and close. Go back to CCC and activate the profile you just created.

This will make the card idle at 300core, 500memory. (2D clocks are the "Want_0" values) http://forums.amd.com/game/messagevi...VIEWTMP=Linear

If the green pixels still occur just try some higher clocks.

I hope this will help some of you to fix this problem :-).

share|improve this answer

Could it be a loose connection? (especially if you're using an adapter for DVI to HDMI)

Otherwise make sure your graphics drivers are up to date.

To figure out if it's hardware or software, see if you can test your laptop with a different screen. Also do the same with your current LCD screen. Test it with a friend's laptop using a different cable.

share|improve this answer

I had a very similar problem. Flickering red and green pixels in dark areas of the screen (and by putting my nose on the wall i project at, I noticed that the white areas had faint yellow pixels). I think it only seems the pixels move with the image, when really the black image makes the underlying errounous pixel pattern visible.

I fixed it by changing the "color pixel format" option in my graphic cards control center; that option has values like "YCbCr 4:4:4".

share|improve this answer

What fixed it for me was to re-plug the video cable tightly (really tightly!) in the video card socket, and make sure it is not bend the first several centimeters - so there is no strain on the socket. Simple solution, perhaps it will help someone too :)

share|improve this answer

I fixed this problem by setting my GAMMA to high on my TV (I am using as a monitor). It was hidden under advanced settings, but for some reason, putting GAMMA to high totally removed all the green areas that were appearing in the dark areas of the screen, that showed up especially strong with dark movies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.