Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Model: Toshiba Satellite A205-S5809

OS: Linux Mint 12

Okay, I've read quite a few posts but none of them seem to solve my problem.

Some things I've tired:

  • Remove battery, unplug, hold down power button for 30 seconds.
  • Plugging it into a power strip. (Seen it suggested somewhere)
  • I attempted what was suggested in this post. But without luck.

I'll start by saying my HDD is about dead, but that isn't causing this problem I believe (Maybe it is though). Here is why I think it's not the HDD. When it's not plugged in it seems to run fine. When I plug it in though it will eventually freeze completely, some times it freezes instantly, and I have to hold down the power button to switch it off. Maybe it's just Linux Mint? Because when I ran Slax on it, it seemed to work just fine but it was running from a CD (So it could be the HDD causing this, but it doesn't happen when plugged in). Any suggestions? It could be this version of Linux maybe. If it is, could someone suggest a different version to try for a Linux beginner?

Thanks a head of time

EDIT I don't know if this makes a difference, but I can mess around in the bios while it's plugged in all day and it won't freeze.

share|improve this question
have you tried running a memory test? It Could be faulty RAM #Edit if it's new, check that it's seated properly. It could be a little loose. Also make sure no dust has gotten into the contacts when it was being installed. – OAC Designs Apr 4 '12 at 0:50
could you be more specific? I cannot see at what specific point your laptop actually refuses to work. – Baarn Apr 4 '12 at 0:50
The RAM I installed is rather new, but that could be it. I'll try that and report back. – Zexanima Apr 4 '12 at 0:52
Memtest86+ is the best one – Tim Apr 4 '12 at 0:55
It comes with a lot of Linux distros – Tim Apr 4 '12 at 0:55

Many of the Toshiba Satellite laptops and some from HP and Dell of the same time period suffer this problem. It is caused by a faulty capacitor that mucks up the power saving features. In Windows 7 you can go into the device manager and go under CPU and select 'disable' for the CPU(s) which apparently disables some of the more advanced features of the processor. I think you may have progress if you can disable the ACPI. If I recall 'ACPI=off' can be added to the grub optional parameters. I'd recommend fiddling along these lines, of trying to disable ACPI or CPU throttling (c states and p states).

Of course the true fix is to replace that capacitor.

share|improve this answer

This should help you find out if your HDD is dead/dying

share|improve this answer
It IS just about dead, Linux says so and scans with various software on a Hirens disk says so. However, it only freezes when plugged in. I don't see how that would have to do with the HDD failing. – Zexanima Apr 4 '12 at 0:57
I preformed a memory test with Memtest86+ No errors. – Zexanima Apr 5 '12 at 1:12
Also, if I run a version of linux like Gentoo or Arch which just use the command line it doesn't freeze when plugged in. – Zexanima Apr 5 '12 at 1:40

If you can work in the BIOS all day, but have issues in Linux, it may be power saving features mucking up Linux. You might be able to turn them off in the BIOS to see it it's the problem.

share|improve this answer
I thought this too, but I don't appear to have any power saving features of any kind in my bios. – Zexanima Apr 4 '12 at 1:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .