Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I'm abroad and access Google's search (via Chrome browser, on my own laptop) or other Google services, they are presented to me in the local language. How can I get Google services displayed in English and instruct Chrome to use (instead of the country-specific site)?

My language setting in Windows is English, so Chrome should already use this by default, and I've also set my language preference in iGoogle to English (U.S.), yet if I'm in France, for example, my searches take place on and sites like the Google News are in French.

Chrome tries to be helpful by suggesting to translate these pages for me, but it would be far better to direct to the original English version of these sites in the first place.

How do I fix this?


This answer to a related question fixed the search issue. However, other Google services, such as Blogspot, still insist on sending me to their localized version.

share|improve this question
possible duplicate of How can I force my browser to search Google in English? – Tom Wijsman Apr 4 '12 at 10:42
<<insert rant about various websites thinking they know better than Accept-Languages>> – Kovensky Apr 4 '12 at 10:42

You can enter as the address. This will force Google to use the US version.

Alternatively, whenever you open a localized version of, there is a link at the bottom which says " in English". This is basically the link above.

If you specifically want to change this setting for Chrome, you should open Settings (Wrench icon --> Settings) and then click on Manage search engines on the first, Basics tab. You should have both Google (default) and to choose from.

share|improve this answer
Thanks, but Chrome ignores the setting. I ended up having to edit one of Chrome's files as suggested by this answer: – Super Chicken Apr 4 '12 at 12:16

Adding a 3rd language to the list of languages in Chrome solved the problem for me.

Originally Chrome was showing "English (United States)" and "English" but Google search results were in Chinese (I'm in Hong Kong). I added "English (United Kingdom)" and now the search results are in english.

Actually adding Afrikaans or any other language seems to solve the problem, so I guess the main thing is that there are multiple languages set.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .