Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use the Speed Dial extension from Chrome and whenever I enter in a new file:// bookmark it automatically converts this to http://file//, and this doesn't work. I have the LocalLink extension so I can use the file URL manually but for some reason this extension just won't play nice. So, this is annoying and since development on this extension is dead I doubt that this will get fixed anytime soon.

So as a work around, is it possible to somehow encode file:// in an HTTP URL? Like http://file%3A//...?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Not trivially. The "http:" scheme expects that HTTP will be used to contact some sort of server. It may be possible to put up a server that performs a redirect to a file: URL, but 1) someone has to put it up, and 2) someone has to pay for the (admittedly small) traffic generated. You should consider asking the addon author to fix it.

share|improve this answer
    
Thanks for the info although I might be more productive trying out one of the other dial extensions rather than trying to get the author to fix it.. –  E.Beach Apr 5 '12 at 0:06
add comment

Adding "file%#A//" would create an the invalid URL. It wouldn't behave in the way that you want it to.

You should either manually edit the bookmark to remove the "http://" or temporarily disable the extension when creating these types of bookmarks.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.