Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Open Office 3.3 on my computer running Windows Vista (Home Premium). I did so after system restoration, and because OpenOffice 3.2 could not be reinstalled (NSIS error), so I downloaded the latest version from OpenOffice.org (in French).

Installation was successful - so did a message on my computer tell me. But when I tried to open .ods, .odt or .odb files, I got the following error message:

The program can't start because sal3.dll is missing from your computer.
Try reinstalling the program to fix this problem.

I ran a search on my computer and sal3.dll could be found in the OpenOffice installation .cab file. So I tried to extract it (I opened it using WinZip), but then I received another error message telling me that extraction had failed.

The error description contained two interesting elements:

  • file superposition is not allowed, which seems to mean that the file is already there although hidden
  • access refused although I created my user account on my PC as an admin account (or at least so did I think)

Stranger still - Open Office is not even featured in the startup menu. I saw it featured during/upon installation (in the "All Programs" page) but now it does not appear any longer. Yet when I attribute .odt, .ods or .odb files to OpenOffice, I do get the correct account in Windows Explorer. And there is a seemingly complete set of folders under "Open Office" in the C:\Programs folder.

share|improve this question
    
OK - I know I'm just answering to myself, but no crowd seems to have been fighting to give an answer since I asked my question... anyway I used the trick described at itechtalk.com/thread3595.html - I edited the System variable instead of the User one, but anyway it works! If anyone is interested... –  jackieh Apr 27 '12 at 11:46
    
One thing still - sal3.dll may be there but not visible if your file explorer (Windows Explorer) has not been set to see hidden files - you may have to restart your computer in order to successfully change the setting (yeah blonde trick, I know I know...) - blondes like me may just happen to surf this forum :-) –  jackieh Apr 27 '12 at 11:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.