Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Mouse's bottom LED goes off after 3 seconds after connection and cursor movements and wheel stops. Pressing any button, reconnecting or resetting USB device resumes it for another 3 seconds (when resumed by pressing button, this event does no go to X).

This happens when using any of USB ports. This mouse works well with other computer with Linux. It was working well before.

Why can it happen? How to fix it?

Update: It happens only if laptop is on battery.

Answer: this is caused by powersaving done by laptop-mode-tools. To temporary turn off powersaving one can use

for i in /sys/bus/usb/devices/*/power/control; do echo on > $i; done
share|improve this question
This only happens on linux, or other operation systems? – soandos Apr 4 '12 at 21:59
I have just observed it. May be reboot will fix it, but I want to know why this can happen. – Vi. Apr 4 '12 at 22:02
My crappy no name wireless mouse does this. It doesn't matter if my computer is plugged in or on battery. To make matters worse, no amount of activity will "unsuspend" the mouse once it gets stuck, forcing me to remove and reinsert the batteries every 3-5 seconds. Useless piece of s**t. – Emanuel Landeholm Jan 1 '15 at 14:49
up vote 1 down vote accepted

This is a normal behaviour of all mouses after they are getting wireless, to save battery. you can adjust it if it has a 3rd party software coming within the box.

share|improve this answer
He doesn't says if it's a wireless mouse. – Renan Apr 4 '12 at 22:13
This is wired USB mouse. – Vi. Apr 4 '12 at 22:17
Ok. I just looked my wired usb mouse and also it is getting inactive after 5 seconds, and this is also for energy saving, because you may use it with a laptop which battery time matters. And isn't it a good feature? – siesta Apr 4 '12 at 22:22
The LED is not dimmed, but is off at all, preventing the normal use of mouse (need to click every time before moving). – Vi. Apr 4 '12 at 22:35
Battery saving? Probably, because of turning the netbook to AC prevents turning off mouse. How to [temporarily] disable such energy saving? – Vi. Apr 4 '12 at 22:36

I have the perfect solution!


for i in /sys/bus/usb/devices/*/power/control; do echo on > $i; done

works for you, but only once, edit /etc/laptop-mode/conf.d/usb-autosuspend.conf to replace :




It works for me.

share|improve this answer
Man, you really said something that makes sense. Thanks! – BrunoJCM Jun 10 '13 at 20:18
I didn't know that I had the 'laptop-mode-tools' package installed.. It may also explain other problems with the cpu scalling indicator I had. – BrunoJCM Jun 10 '13 at 20:20
Thanks, you've saved my life! – kurp Jun 20 '15 at 22:16

It's a very old question, related with laptop-mode, but I'll post my solution:

In Ubuntu 14.04 I edited /etc/laptop-mode/conf.d/usb-autosuspend.conf and change this lines to blacklist usbhid:

# The list of USB driver types that should not use autosuspend.  The driver
# type is given by "DRIVER=..." in a USB device's uevent file.
# Example: AUTOSUSPEND_USBID_BLACKLIST="usbhid usb-storage"

In Ubuntu 12.04 I must to edit /etc/laptop-mode/conf.d/runtime-pm.conf and change this lines to blacklist usbhid:

# The list of device driver types that should use autosuspend.  The driver
# type is given by "DRIVER=..." in a device's uevent file.
# Example: AUTOSUSPEND_DEVTYPE_WHITELIST="usbhid usb-storage"

You can also blacklist usb-storage! and you can also blacklist device by ID (AUTOSUSPEND_RUNTIME_DEVID_WHITELIST in Ubuntu 12.04 or AUTOSUSPEND_USBID_BLACKLIST in Ubuntu 14.04).

Then you'll need to restart laptop mode for the changes to take effect:

sudo /etc/init.d/laptop-mode restart

And then replug mouse. The mouse will not suspend again.

This works for me at work (ubuntu 12.04) and home (ubuntu 14.04).

Hope It helps :)

share|improve this answer
This answer solved my problem in Debian. I blacklisted usbhid and psmouse and after restarting laptop-mode service, and replug my mouse, the issue is solved – Sharuzzaman Ahmat Raslan Jan 15 at 11:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.