Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a batch file that does several things, and among them is:

dir "\\network_share\directory" /Q /A:-D /S > output.txt

The file then writes out lines like this:

01/01/2012 01:01 PM 100,000 DOMAIN\user filename.doc

However, when I ran the same script while VPN'ed in, the results were as follows:

01/01/2012 01:01 PM 100,000 . . . filename.doc

Odd thing is that if I go to that folder in Windows Explorer, and enable the Owner column, I can see the data just fine.

What can be causing this behavior and how do I correct it to work over VPN?

share|improve this question
Are the two DIR commands being run from the same machine? If not, what OS's are the two machines running? – Chris_K Apr 5 '12 at 1:23
Tried from the same machine (Windows 7), and tried from a virtual XP. I can't seem to find any documentation on what ". . ." means in response to /Q. – djdy Apr 5 '12 at 1:41

You must log in to answer this question.

Browse other questions tagged .