Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I type this in the terminal

chmod -R g+r "/media/truecrypt1/My folder/"*

and then check the result wiht

ls -l

I still get

-rwx------ 1 user user 127860 2012-03-16 15:45 sample.pdf

What's wrong?

I've also tried sudo, but it didn't work.

share|improve this question

migrated from stackoverflow.com Apr 5 '12 at 9:16

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

try this.

chmod -R g=r "/media/truecrypt1/My folder/"*

share|improve this answer
    
Thanks but it doesn't work –  user1294101 Apr 4 '12 at 11:08
1  
did you try with root user? –  Aykut Apr 4 '12 at 11:09
    
I've tried with sudo but nothing. –  user1294101 Apr 4 '12 at 11:10
3  
if your media is ntfs (apperantely it is) chmod or chown does not work for ntfs.You can mount your ntfs media manually with giving exact permission.Something like sudo mount -t ntfs -o rw,auto,user,fmask=0022,dmask=0000 /dev/whatever /mnt/whatever –  Aykut Apr 4 '12 at 11:15
    
Thank you so much. Now I can understand. –  Surfer on the fall Apr 5 '12 at 11:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.