Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old IDE hard drive that has some data I must recover, so I bought an usb adapter to plug it to my new pc and copy everything.

But Windows installed the drivers when I plugged it in, but couldn't get it to initialise using the disk utilities from computer management.

So I tried on Ubuntu, and while it shows up with lsusb and also on the disk utility, I can't access it with gParted or mount it manually.

Now, there's any way to access the data without formatting?

And I don't think it's a problem with the hdd as well.

edit: the lsusb output:

Bus 002 Device 005: ID 05e3:0718 Genesys Logic, Inc. 
Bus 002 Device 003: ID 04f2:b1aa Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 045e:009d Microsoft Corp. Wireless Optical Desktop 3.0
Bus 001 Device 004: ID 03f0:231d Hewlett-Packard 
Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And the dmesg | grep sdc output:

[  120.588527] sd 5:0:0:0: [sdc] Attached SCSI disk
[  409.551010] sd 6:0:0:0: [sdc] Attached SCSI disk

I also tried to mount it with the following options (I don't know the file system):

Mounting as fat

sudo mount -t vfat /dev/sdc /mnt/sdc -o iocharset=utf8,umask=000

Output:

mount: /dev/sdc: can't read superblock

Mounting as ntfs

sudo mount -t ntfs /dev/sdc /mnt/sdc -o nls=utf8,umask=0222

Output:

Failed to read bootsector (size=0)
Failed to mount '/dev/sdc': Invalid argument
The device '/dev/sdc' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
share|improve this question
    
What file system is the drive using? –  Joachim Isaksson Apr 5 '12 at 15:04
    
So, what do you get in Ubuntu? Access to the device (/dev/sdb), the partition (/dev/sdb1), something else? –  Oliver Salzburg Apr 5 '12 at 15:04
    
Stupid question, but are the master/slave pins on the drive set correctly? –  Yitzchak Apr 5 '12 at 15:27
    
I said I don't know the file system of the driver. I don't have access to anything, but only the device is showing up, Ubuntu can't read even the size of the disk. The pins are set to the only slave option. The cat only outputs the native hard drive and its partitions. –  Rodrigo Apr 5 '12 at 16:53
    
And Ubuntu's Disk Utility says that the device is not partitioned –  Rodrigo Apr 5 '12 at 16:55

1 Answer 1

First things first (besides the select jumpers) - are you following the proper power-up sequence?

Connect the IDE-USB adapter to the HDD. Then apply power to the HDD; the HDD must be spinning and ready (heads unlocked) before you plug in the USB cable at the PC.

And be very careful to not jostle the drive while it is powered on!

share|improve this answer
    
Problem is that under windows you can plug the usb adapter to PC and then connect it to disk and it works fine. I killed over 2 hrs finding the right kernel driver and it was THAT simple. Thank you very much! –  andrej May 19 '12 at 13:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.