Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this very weird issue with my Linksys E1000 router.

The network itself works just fine, but for some reason the router doesn't let any browser connect to its web interface, except Safari and links. (I tested Chrome, Firefox, Opera, IE, on Mac/Windows)

Every single browser except Safari and links says some variation of the message The connection was reset.

I can live with this, except it's annoying that I always have to use my Mac with Safari to administer the router.

Any idea about what might be causing this and how to fix this? I have tried rebooting the router several times, but no dice.

share|improve this question
    
Check your proxy settings. This sounds like you have a proxy outside your network and you can't reach a computer on your network through a proxy outside it. –  David Schwartz Apr 6 '12 at 1:55
    
@DavidSchwartz: just checked, Firefox is set to "No proxy". –  houbysoft Apr 6 '12 at 2:33
    
@DavidSchwartz: also, if it helps, the web interface on the router is set to use HTTPS. However, the HTTPS certificate of the router is not trusted, so when I try to connect, it asks me if I really want to go to that page, seeing as the certificate is not trusted, I click yes, and only then does it show The connection was reset. So it would seem that the web browser communicates with the router, it's just that at some point in the connection, the router resets the connection... –  houbysoft Apr 6 '12 at 2:38
add comment

1 Answer

up vote 0 down vote accepted

I have the same router and the same issue, I think the reason might be detailed in this post: http://support.mozilla.org/en-US/questions/918127

Response by cww:

There was a security protocol change that was introduced in Firefox 10 (as well as in Chrome 18 and in IE9 with the latest security patch from Microsoft) to address a particular vulnerability. Some poorly coded sites/pages are taking a shortcut when interpreting the secured data stream and now that the format has changed they don't handle the change gracefully and bail on the connection.

As for options, you can see if the router will accept non-HTTPs connections which should be fine or you can try to contact Cisco to make a firmware update to support this new protocol.

share|improve this answer
    
Ah... good to know I'm not the only one, although honestly I highly doubt Cisco will bother to make a patch. I've just updated to the latest version (2.1.02), and the issue's still there. –  houbysoft Apr 19 '12 at 22:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.