Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I did something stupid. I reinstalled Windows on my computer but decided to leave the old installation on the drive instead of reformatting. Now I'm trying to delete the old Windows folder and for the most part have been successful, but cannot for the life of me delete two files:

  1. E:\Windows\System32\Macromed\Flash\Flash64_11_1_102.ocx
  2. E:\Windows\SysWOW64\Macromed\Flash\Flash11e.ocx

When I try to delete the files I get the error

You need permission to perform this action

You require permission from Nathan-PC\Nathan to make changes to this file

I tried changing the permissions as explained in this guide: http://helpdeskgeek.com/windows-7/windows-7-how-to-delete-files-protected-by-trustedinstaller/, but I still cannot delete the file.

I initially got this error for many/all of the files in the old Windows folder, but I read this: http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/, and downloaded and ran the "take ownership" script. After running that command on the directory I was able to delete all but the two files above.

I have tried everything in normal mode and safe mode.

This is driving me nuts! Can anyone help me delete these two files?

Windows shall not defeat me!

share|improve this question

marked as duplicate by DavidPostill windows Jun 1 at 9:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Have you tried to use unlocker? Available here filehippo.com/download_unlocker – avirk Apr 6 '12 at 2:28
up vote 1 down vote accepted

Download the unlocker. After installing this you will able to find it just right click on the folder you want to delete and select the unlocker, it will assist you to perform the delete, rename and move the folder and now its depend on you what you want to do with the folder.

enter image description here

enter image description here

share|improve this answer
    
Thank you very much! – Nate Apr 16 '12 at 1:13

Check this answer : Cannot delete flash9.ocx , for me it worked when removing old Windows folder from a second partition which was primarily boot partition before adding an SSD to my laptop.

Basically, Adobe just denies the user to change Write attributes on their OCX files. In my case, as also explained on the above link, Everyone had Deny checked; after removing this constraint, deletion worked without problems.

share|improve this answer

If everything else fails, you can always circumvent Windows entirely.

  1. Download Ubuntu.

  2. Burn your CD or create a bootable USB stick.

  3. Reboot using the CD or the USB stick.

  4. Delete the files.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .