Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently built a system based on a GIGABYTE G31M-ES2L motherboard, which has an Atheros AR8131 onboard LAN controller. The system runs fine, but I am unable to connect to the Internet in any operating system I have tried, leading me to believe this is a hardware problem.

-In Windows XP, latest driver is installed and the controller is recognized and listed as "working properly" in Device Manager, but no connection can be established

-Linux kernel 3.2 detects the controller, but no connection can be established

-Onboard LAN is enabled in the BIOS (I have triple-triple checked this)

-Connecting an Ethernet cable to the motherboard activates both LEDs on the port, indicating that the cable is detected

-My router setup itself is fine, as I am writing this post on a wired connection from my notebook, and I have also tried connecting directly through the modem with no luck

-The LAN chip itself, as located via my mainboard's product manual, is physically intact

I've thus checked every avenue that I'm aware of. Is there anything else that could be causing this problem? Do I just have a defective piece of hardware?

share|improve this question
1  
I'd pick an OS and stick with it whilst you try and troubleshoot. In XP when it all looked like it was configured ok did you try pinging the localhost - if this fails it indicates a card/config error. Always a good first test. –  BJ292 Apr 6 '12 at 12:16
    
Does the ethernet port light up when a cable is plugged in? Have you tried swapping ethernet cables? Swapping ports on your router? –  jmreicha Apr 6 '12 at 16:24

2 Answers 2

Tried troubleshooting more without any results, so gave up in frustration and used solely my notebook for a few days... then randomly fired up this system again, and, magic? connection established. I have no idea how this happened, considering that I made no changes to my setup or configuration. YMMV may vary sometimes, I guess.

Thanks for the responses.

share|improve this answer

You need LATEST DRIVER

Do you get to see it using OpenBSD boot disk?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.