Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I tried to re install Ubuntu 11.10, I wanted to erase the existing Ubuntu using gparted editor/ something else icon in Ubuntu. I found it was not detecting any existing partition.

Then when I googled and used gparted editor I found it was showing unallocated space of entire hard disk space. However I am able to boot to Ubuntu normally and when I use disk utilities I am able to access and see all partitions. Please help me to solve my issue

share|improve this question
add comment

3 Answers

Try to use the latest version of Ubuntu if possible. During the installation process you should be able to erase disk completely and create new partition.

share|improve this answer
add comment

This is almost always due to a corrupt partition table, which causes gparted to show the drive as being empty. Run sudo parted /dev/sda print to try and look at the partition table from the command line and it will probably report what the error is.

share|improve this answer
add comment

If your HDD is plugged into a non-standard SATA port it may not be seen by Ubuntu. Gigabyte for example have GSATA, which is currently unsupported at least as of a couple of months ago. It is worth checking if for any reason the software cannot see the HDD.

share|improve this answer
    
Some quick googling indicates that this "GSATA" nonsense is just some marketing B.S. label for the ports coming from the JMicron standard AHCI SATA controller. In any case, he said the drive is seen just fine; it's the partitions that he's having trouble with. –  psusi Apr 7 '12 at 1:52
    
It is still worth checking because if he can't see the partition for any reason and he happens to have it plugged into a GSATA port, that is going to be the reason why. But you are right that I am not concerning myself too much in the details here - only that it might have slight relevance. –  defaye Apr 7 '12 at 1:57
    
No, it is not going to be the reason why. As I said, this GSATA port nonsense is just a bog standard SATA port that Ubuntu is already recognizing and accessing the drive just fine. –  psusi Apr 7 '12 at 2:06
    
Yes you are right. My answer is out of place - he already installed it so it must be using a standard SATA port - the drive was corrupted. But you know what @psusi, if someone has a motherboard with this kind of port described, they may have problems installing ubuntu, my answer is not nonsense, I know it for a fact as of version 11.10 –  defaye Apr 7 '12 at 3:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.