Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently I have this setup:

  1. D-Link DSL2640U connected to the phone line:
    • VPI/VCI 0/40, Service Category UBR Without PCR
    • Service pppoe_0_40_3
    • Interface nas_0_40
    • Protocol Bridging (LLC/SNAP-Bridging)
    • 802.11q not enabled
    • Bridge Service Enabled
  2. Computers have individual PPPoE connections (in Network and Sharing Centre -> Set up a new connection or network -> Connect to the Internet -> Broadband (PPPoE) -> Username and Password)

How would I move these settings on each individual PC to the router so that all I need to do is connect to the wireless? I have been unsuccessful setting up anything other than Windows PCs on the network (I have tried Macs, iOS and Nokia SmartPhones too).

Thanks for the responses in advance!

share|improve this question

migrated from serverfault.com Apr 6 '12 at 13:40

This question came from our site for system and network administrators.

2 Answers 2

You need ask your ISP to do it for you or you need to find auto authentication option in your PPPOE settings where it ask for username and password.

share|improve this answer
    
I have already attempted to use the PPPoE settings in the router (instead of bridged) to enable the router to log in itself, but it does not result in connectivity. Unfortunately I am trying to set this up in Kazakhstan, where the ISP support is all in Russian, so they have not been helpful either (through no fault of their own - I do no speak Russian, and Google Translate only goes so far). –  João Lourenço Apr 6 '12 at 18:21

Turns out that the issue was that the NAT was turned off. The PPPoE authentication now works fine :). Thanks for the input.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.