Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A client of mine has been complaining about a particular Excel workbook (Excel file) that is running very slowly.

Whenever they try to make changes to any of the cells, it takes about 10-20 seconds to make the change. Excel freezes up and becomes unresponsive during this time.

I've tested this file on several different machines to ensure it wasn't a problem with the machine. It runs very slowly on all 3 machines I've tested.

It's a .xls file, meaning it is Excel 97-2003 format.

The workbook doesn't do any calculations or make use of any formulas at all, and cells don't refer to other cells. The workbook is simply used to store tabular data, and contains about 12 worksheets, and is about 4mb in size.

Any ideas on what the problem could be, and how to resolve this issue?

Update:

  • I am using Excel 2007. Haven't been able to get hold of earlier versions of Excel to test on.
  • I've managed to narrow the problem down to the latest worksheet in the file/workbook. All the other worksheets are very fast. No problems there.
share|improve this question
    
if you never solved this, or even if you did, I can recommend an analysis product called FastExcel, sold at decisionmodels.com –  jtolle Aug 7 '10 at 18:04
    
try switching your default printer to another choice (if one available). my default is a network printer and whilst working at home i can't use it and found it slowing down any excel 2003 spreadsheet. –  user127365 Apr 9 '12 at 14:45
add comment

5 Answers

up vote 2 down vote accepted

Have you tried simply copying the worksheets into a new spreadsheet? This fixes many goofy Excel issues.

share|improve this answer
1  
I'll go for this as well as another option, making sure to Paste Special > Values to make sure there are definitely no formulae. –  user3463 Sep 14 '09 at 13:59
    
I will try this and post results here. –  Saajid Ismail Sep 14 '09 at 14:55
    
Thanks people.. This fixed up the issue... –  Saajid Ismail Oct 28 '09 at 16:16
add comment

Check the formatting.

If individual cells are formatted with colour, border etc. instead of entire columns or rows then the file size and speed of the workbook will be impacted. Check also that there is no conditional formatting applied to any of the cells - this is a killer in terms of performance. In a workbook with many thousands of data cells this can get quite noticeable.

Most of the time this formatting can be stripped out and replaced with column/row formatting without any major impact on the look of the worksheets.

share|improve this answer
add comment

Ensure empty rows and columns are really empty, by removing them once again. In old versions of Excel this will give you new empty rows and columns; in later version you might not see those.

To remove: right-click and select something like "Delete Rows". Do not press the Delete key, which would only delete the empty contents and does not help you.

To select: select the first empty row below the data, then hold down Shift, and press End followed by Down one or two times. Likewise: select the first empty column, keep Shift down, and press End followed by Right one or two times. (I am not 100% about the keys. You can also try Ctrl-Shift-End to extend the selection to the last cell in the sheet.)

share|improve this answer
1  
Good shout. I use David McRitchie's MakeLastCell for this all the time mvps.org/dmcritchie/excel/lastcell.htm –  Lunatik Sep 15 '09 at 11:01
add comment

Open the Excel file in Excel 2007 and save it in the Excel 2007 format (.xlsx) - it will solve your problem. I had a similar issue and this resolved it.

share|improve this answer
add comment

Change from Automatic to Manual Calculation and see if it's still slow. If so, then you can safely rule out calcs, but my Spidey-senses say otherwise.

share|improve this answer
    
I've tried this. It doesn't make a difference. The spreadsheet doesn't make much (if any) use of calculations/formulas. –  Saajid Ismail Sep 14 '09 at 14:51
add comment

protected by slhck Jul 27 '12 at 21:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.