Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an iOmega eGo 320GB portable drive connected through USB2.0 to my laptop running Windows Vista. It's been working fine for quite some time until recently it became very slow when writing e.g. when copying ~300MB movie over to the drive at first it is extremely fast but it actually doesn't write it only puts in cache and then hangs on last 10-20MBs for about a minute. When copying larger files it's the same story: starts fast but then slows down to ~5MB/s (sometimes even slower down to 2MB/s). Strange thing is that I have always had caching disabled for this drive (it was disabled by default and I never bothered changing it).

At first I thought that the disk is dying so I checked S.M.A.R.T. values and everything is fine there. I also run chkdsk and it seemed to fix the problem - it worked fast for a few minutes but then it slowed down again. I also tried plugging it into another USB port - no difference.

Additionally I noticed that reading under certain circumstances is sometimes slower e.g. loading times for some games are ~10 times longer, whereas simple copying files from this drive to my internal HDD is fast.

I ran a speed benchmark using CrystalDiskMark with a 5x100MB run and strangely got these results:

       read   write (MB/s)
   Seq 33.05  28.25
  512k 17.30  15.27
    4k 0.267  0.372
4kQD32 0.510  0.260

This is different from what most other people have (I've found many threads about slow disk write while googling but all of them were slow on benchmarks too) which is why I decided to post this problem here.

BTW most of the time when writing (or sometimes reading) the activity led is mostly idle (blinks a while and then stops for longer, sometimes has slower blinks ~1 sek, sometimes goes off for a few seconds - extremely long blink :) ) but when benchmarking, defragmenting or just reading (copying from this drive, installing apps from installers there, watching HD videos) it is blinking really fast (like it should) and there are no slowdowns.

It shouldn't be driver issue unless stock Windows drivers have some issues I'm not aware of.

share|improve this question
Have you tried defragmenting/formatting the disk? – kotekzot Apr 7 '12 at 8:41
@kotekzot Defragmenting yes, but not formatting (I have nowhere to backup all the data). – matix2267 Apr 7 '12 at 8:46
You have a bunch of data that you only have room to store in one place, and that place is a (1) portable disk and (2) is behaving strangely? Before doing anything else, I would ensure you have a backup of this data. – Paul Apr 7 '12 at 12:16
@Paul It isn't that much important data (mostly downloaded music/videos and installed games/backups of other things that are stored elsewhere) so I don't need to backup it but still if the disk died on me it would take quite a long time to redownload/reinstall everything – matix2267 Apr 9 '12 at 18:38
up vote 1 down vote accepted

I will personally suggest you first of all defragmentation of the disk. If the problem still persist then back up your all data from the external HD and delete the partition from the drive and create them again. I'm much sure that it will solve your problem because the same issue was with my own HD and I did a clean format of all partition and problem gone. Before formatting it was giving me the 12-13mb writing speed and after formatting it is now 20-25mb writing speed.

Before execute above instructions I'll suggest you to connect your device to PC and then go to Device Manager>Disk Drives>Your EXHD right click on HD and select properties and in Policies tab check if you have enabled the Writing disk cache.

enter image description here

share|improve this answer
Any reason why it would help? Is it a filesystem issue? (Did someone prove that windows NTFS filesystem "bloats" itself over the time?) If so then what are the steps to avoid it in the future? Why when writing disk isn't "busy" but instead is mostly idle? CPU usage is normal when writing (no 100% CPU utilisation all the time :) ). I have already defragmented the disk and it didn't solve the problem. – matix2267 Apr 9 '12 at 18:43
I'm not sure about it, but one thing I can say that some time creating and formatting the partition in Windows does not go right(I've also seen some USB does not perform well when they format in NTFS mode) so we should try them to format or recreate the partition. I'll suggest you again that recreate the partition once again. May be its your luck. – avirk Apr 10 '12 at 1:41
Check the edited answer. – avirk Apr 10 '12 at 2:00
I'm not exactly sure why it helped (especially that when the cache was disabled it still cached writes - at first copying files was fast then it slowed down which means it was using cache) but it did help. Windows is very strange: disabling cache means slower writes but still using cache? WTF? – matix2267 Apr 10 '12 at 9:42

Because the program you use is BUGGY.

Please note that CrystalDiskMark was seriously bugged. I used to use it. The data generated by it was not reliable. After so many years they released recently a new version but who can trust them now? Quote from their web site: "CrystalDiskMark 1.0/2.0/2.1 has critical bug!! Please use 2.2 or later".

Also note this hilarious note on their web site: ""MB/s" means 1,000,000byte/sec".

So, is they show read speed of 100MB but it is actually a different number because: 1) of the internal bug 2) their strange way to compute the MB

I would recommend you to activate the 'cache writing' option but first get a decent program (I use now Disk Tools - but you can get any other RELIABLE program) to see the actual speed of the disk.

share|improve this answer
I have to wonder the reason the author tested a 100MB file instead of a 300MB of file. – Ramhound Jun 7 '12 at 15:10
How's that note hilarious? Harddisks are famous for not deciding between binary and decimal. They have 512 or 4096 bytes per sector, but not 1.048.575 bytes per MB. – MSalters Jun 7 '12 at 15:16
@MSalters - when you want to know how fast your disk is, you want to know its real speed (real KB/sec) or its "non-decided" (pseudo-BK/sec) speed? – SolarWind Jun 9 '12 at 14:27
Actually, I tend to care more about IOPS. But when it comes to transfer speeds, I would expect that I can read a 100 GB disk @ 100 MB/sec in 1000 seconds. Since disk sizes are always in "decimal GB", disk speeds are too. – MSalters Jun 11 '12 at 8:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .