Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a SUBST for a folder to drive letter P:

I have noticed that exploring these folders from P: is now INCREDIBLY slow, taking up to a minute sometimes to show files. I'm showing them as general files and not thumbnails, so it's not that.

Looking at the original folder in explorer is lightning fast.

I've checked the indexing options and indeed the folder where my files are stored is checked as indexed. I can see my P: drive in the list, but clicking on the checkbox won't do anything. It's not even checkable.

Does anyone have any clues as to how I can fix this?

(Running Windows 7 just to be clear).

share|improve this question

Map a drive to a path, just like on network share, but locally. By NET command or in explorer.

share|improve this answer
In explorer you can map drive to a local folder by, for example, \\localhost\c$\Windows. – pbies Nov 20 '12 at 18:52
Did't help, some folders are loading for ages. AFAIK, NET is based on SUBST. – Olegs Jeremejevs Nov 20 '12 at 19:15

Go to Control Panel / Indexing Options, to see all the currently indexed locations.

Click the Modify button and a screen will come up that, if P is listed, will allow you to specify the P drive as indexed by clicking on the check-box. Then click OK.

To have effect, this requires a reboot and may take some time.

share|improve this answer
Yes, this worked, thanks. On Windows 8 a reboot isn't required. However, Andy said that the relevant check-box is disabled for some reason, hence, this can't be considered as a complete answer to the original question. P.S. I will award the bounty in one hour. – Olegs Jeremejevs Nov 21 '12 at 15:56
@OlegsJeremejevs: Do you mean that Windows 8 doesn't agree to index subst drives ? – harrymc Nov 21 '12 at 17:57
No, in my case it worked just fine (actually, I enabled indexing yesterday, but since I can't cancel bounty I decided to wait for a proper answer). I pointed out, that question author's problem is a bit different. – Olegs Jeremejevs Nov 21 '12 at 18:08
If Andy doesn't come up and describe better his problem it can be anything : my above answer, slow browsing or even search service stopped. – harrymc Nov 21 '12 at 18:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .