Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just built up a new W7 PC. I've noticed some strange issues with launching default applications.

I've got Visual Studio & SQL Server Management Studio set run as administrator when launched.

If i double click a .sql file SSMS opens ok but the file itself does not get loaded.

If I do the same with a .sln then I get nothing at all from Visual Studio.

For the latter I presume the UAC prompt is hidden somewhere waiting for me to say it's ok to launch the app but i've no idea what's happening with SSMS.

Is this a W7 bug or are there some settings somewhere that I can tweak to improve this behaviour?

share|improve this question
    
Visual Studio shouldn't require a UAC prompt I don't believe (depending on the location of your .sln), so I think you might be having other issues. Quick test for that would be to disable UAC temporarily and see if your problem is fixed. Also, make sure you have SP1 for VS9 as well (I'm not sure how VS8 works on 7). –  Will Eddins Sep 14 '09 at 14:40
    
SP1 is on, I'm running VS as admin to debug applications on IIS rather than using the internal web server. –  Chris W Sep 14 '09 at 14:52

3 Answers 3

up vote 1 down vote accepted

Double check that you have the application executable set to running as administrator for all users and not just the shortcut.

  • Right Click Shortcut
  • Click on Open File Location
  • Right Click on Executable
  • Select Compatibility
  • Select change for all users
  • Tick Run as Administrator

You can similate this when running notepad and explorer for example and it is by design in Windows 7.

  • Run notepad as administrator
  • Open a folder containing a Text file in Explorer
  • Drag file to notepad
  • Nothing happens

Effectively the system is trying to cross boundaries security wise which is not allowed in Windows. The above solution worked fine for me in both scenarios thought on both Vista and Windows 7.

share|improve this answer
    
No joy with this. In the case of SSMS it gives the error 'there was a problem sending a command to the program' but still the file won't open. Visual Studio is still just not even opening. –  Chris W Sep 14 '09 at 14:32
    
@Diago: (OT) hey just dropped by to say thanks for all the help, and apologies for any trouble given. Glad to be back too. –  caliban Sep 14 '09 at 16:52
    
SQL Server is still proving buggy but your answer set me on the way with Visual Studio. I'd ignored the fact that VS by default runs a launcher which picks the version of visual studio to then run hence your boundary argument was spot on. I granted the devenv.exe run as admin rights and swapped the default app to go direct to devenv and bypass the VS launcher. –  Chris W Sep 15 '09 at 8:19
    
@Chris - The SSMS problem concerns me. Changes are that there is something weird in the registry or associations. To confirm, I reconfigured all mine again now, since I stopped running these as administrator a while ago, and it is working for me on both. Unfortunatly I am out of any other creative ideas :( –  Diago Sep 15 '09 at 9:28

Enable "run as admin" for both devenv.exe AND VSLanucher.exe doesn't solve the same issue on my machine (Windows Server 2008 R2 Enterprise SP1 + Visual Studio 2010 Ultimate). But turning off UAC and restart machine once can solve the issue.

[Update] Ok, after looking around my machine's configuration, seems that the default application associated to .sln file is VSLanucher.exe. After changing default application to VS2010 it's now working!

share|improve this answer

I had the same issue described with Visual Studio--setting devenv.exe to run as administrator on W7 causes double-clicking on sln files to fail. I found that setting BOTH devenv.exe AND VSLauncher.exe (found under Files (x86)\Common Files\microsoft shared\MSEnv) to run as administrator resolved the issue and now double clicking sln files launches VS as an administrator.

-Forrest

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.