Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently developed a problem with Google Chrome that's really annoying. I'm using Firefox at the moment with no problems whatsoever and it's the same with IE, so it's safe to say this problem is specific to Chrome. The problem is that it's not accepting security certificates from certain sites.

I suppose the best place to start would be google itself. I can't search. The google search page will load but when I type some search term into the search box and hit 'search' I get the message:

"You attempted to reach www.google.com, but the server presented an invalid certificate. You cannot proceed because the website operator has requested heightened security for this domain."

No matter what the search term is, this is the result. Also when I try to log in to facebook - same message. Youtube works and many other sites that I know present security certs so I'm baffled. I've searched and there are other people who have had similar issues but I can't find a solution anywhere. The most common answer I'm picking up for this is to "check your system time" but I can safely say that it's not my system time.

If anyone knows what is going on, I'd very much appreciate being informed. It's not super urgent as I can use Firefox to access those places Chrome won't, but it IS super annoying because I can usually sort out issues like this in no time.

share|improve this question

3 Answers 3

Another possibility of seeing security certificate errors is because your local machine's time is out of sync. Update your system date/time to solve the problem.

share|improve this answer
    
And most likely you are off by years. –  David Schwartz Feb 1 '13 at 22:55

Seems that Chrome was recently hit with a bug that is causing this issue.

http://www.slashgear.com/google-chrome-hit-by-ssl-bug-restricting-google-services-06221921/

and

http://groups.google.com/a/googleproductforums.com/forum/#!category-topic/chrome/report-a-problem-and-get-troubleshooting-help/yHclY2CexIE

seem to confirm this. The issue appears to be with the latest version of Chrome running on Windows 7 64-bit.

Edit:

From here: http://code.google.com/p/chromium/issues/detail?id=118706

It appears that if i delete "chrome_shutdown_ms.txt" from the User Data folder then all websites open correctly (gmail, etc). However, the problem reappears upon restarting the browser since the file is recreated on exit.

share|improve this answer
    
Thanks - that's a good stop-gap solution there. Would point out that in order to see the file "chrome_shutdown_ms.txt you first have to close chrome. Delete it and restart chrome for normal browsing ;) –  Jerry Apr 8 '12 at 3:26

You can get rid of this problem by clearing all browsing data.

  1. Go to Settings > Under the Hood > Clear Browsing Data
  2. For "Obliterate the following items from", select: "The beginning of time"
  3. Select all items because you don't know which certificate caused the crash.
  4. Click "Clear browsing data".

This will clear all passwords, history, bookmarks, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.