Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I noticed that there is a command - rpm - under Cygwin 1.7. Does that mean RPM packages can be installed into Cygwin?

I tried to install ncbi-blast-2.2.26+-3.i686.rpm (see: ftp://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/LATEST/) into Cygwin 1.7.13 with the command "install -i ncbi-blast-2.2.26+-3.i686.rpm". However, this error message appeared.

I tried to search for the missing libs using the setup.exe of Cygwin. It seems that some of them were not present, such as libc.so.6, libdl.so.2, libm.so.6, libnsl.so.1, and libz.so.1. Where can I get these libs?

$ rpm -i ncbi-blast-2.2.26+-3.i686.rpm
    error: Failed dependencies:
    /usr/bin/perl is needed by ncbi-blast-2.2.26+-3
    libbz2.so.1 is needed by ncbi-blast-2.2.26+-3
    libc.so.6 is needed by ncbi-blast-2.2.26+-3
    libc.so.6(GLIBC_2.0) is needed by ncbi-blast-2.2.26+-3
    libc.so.6(GLIBC_2.1) is needed by ncbi-blast-2.2.26+-3
    libc.so.6(GLIBC_2.1.2) is needed by ncbi-blast-2.2.26+-3
    libc.so.6(GLIBC_2.1.3) is needed by ncbi-blast-2.2.26+-3
    libc.so.6(GLIBC_2.2) is needed by ncbi-blast-2.2.26+-3
    libc.so.6(GLIBC_2.3) is needed by ncbi-blast-2.2.26+-3
    libdl.so.2 is needed by ncbi-blast-2.2.26+-3
    libdl.so.2(GLIBC_2.0) is needed by ncbi-blast-2.2.26+-3
    libdl.so.2(GLIBC_2.1) is needed by ncbi-blast-2.2.26+-3
    libgcc_s.so.1 is needed by ncbi-blast-2.2.26+-3
    libgcc_s.so.1(GCC_3.0) is needed by ncbi-blast-2.2.26+-3
    libgcc_s.so.1(GLIBC_2.0) is needed by ncbi-blast-2.2.26+-3
    libm.so.6 is needed by ncbi-blast-2.2.26+-3
    libnsl.so.1 is needed by ncbi-blast-2.2.26+-3
    libpthread.so.0 is needed by ncbi-blast-2.2.26+-3
    libpthread.so.0(GLIBC_2.0) is needed by ncbi-blast-2.2.26+-3
    libpthread.so.0(GLIBC_2.1) is needed by ncbi-blast-2.2.26+-3
    libpthread.so.0(GLIBC_2.2) is needed by ncbi-blast-2.2.26+-3
    libpthread.so.0(GLIBC_2.3.2) is needed by ncbi-blast-2.2.26+-3
    librt.so.1 is needed by ncbi-blast-2.2.26+-3
    libstdc++.so.6 is needed by ncbi-blast-2.2.26+-3
    libstdc++.so.6(CXXABI_1.3) is needed by ncbi-blast-2.2.26+-3
    libstdc++.so.6(GLIBCXX_3.4) is needed by ncbi-blast-2.2.26+-3
    libstdc++.so.6(GLIBCXX_3.4.5) is needed by ncbi-blast-2.2.26+-3
    libz.so.1 is needed by ncbi-blast-2.2.26+-3
    perl(Archive::Tar) is needed by ncbi-blast-2.2.26+-3
    perl(Digest::MD5) is needed by ncbi-blast-2.2.26+-3
    perl(File::Temp) is needed by ncbi-blast-2.2.26+-3
    perl(File::stat) is needed by ncbi-blast-2.2.26+-3
    perl(Getopt::Long) is needed by ncbi-blast-2.2.26+-3
    perl(Net::FTP) is needed by ncbi-blast-2.2.26+-3
    perl(Pod::Usage) is needed by ncbi-blast-2.2.26+-3
    perl(constant) is needed by ncbi-blast-2.2.26+-3
    perl(strict) is needed by ncbi-blast-2.2.26+-3
    perl(warnings) is needed by ncbi-blast-2.2.26+-3
share|improve this question

2 Answers 2

In your case, it's visible from the missing files that this RPM is aimed at Linux, and will not work in Windows.

rpm support in Cygwin is meant to be used for building your own RPM packages.

share|improve this answer

Yes. But you cannot install arbitrary RPMs into Cygwin; they must be created specifically for the appropriate arch of Cygwin, and they must have all dependencies as RPMs as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.