Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My old router (Voyager 2091) packed up so I just got a new router - a Netgear N150 model DGN1000.

My laptop connects OK wirelessly, but my iPhone 4S is constantly getting "disconnected" - it has perfect wifi signal and is seemingly connected to the router, but no pages load (it says "server cannot be found").

If I disconnect manually ("forget this network") then reconnect, it works fine again for a random amount of time (usually 10-30 minutes) then I get the same problem again.

I've done some searching and this appears to be a known problem - there are dozens of forum posts out there lamenting similar connection problems. The only advice I have seen is to set a specific channel under Wireless Settings on the router CP, although every forum post recommends a different channel! 1, 3, 5, 6, 11... I have tried them all for hours at a time and get the exact same problem. The firmware is up to date.

Is there an actual solution for this, or do I need to get a different router just to be able to use my iPhone?

share|improve this question
Exactly which iOS version are you running on your iPhone 4S? – Spiff Apr 9 '12 at 0:08
By the way, OF COURSE no one can tell you which channel will be best for you! They have no idea which channels are most polluted in your house. All they can tell you is which channel was least polluted in their own house. – Spiff Apr 9 '12 at 0:10
@Spiff what exactly causes a channel to be 'polluted'? We don't have any other wifi connections here, although occasionally we can see next door's wifi. But it's not a problem for the laptop on this wifi, nor was it for any device on the old router. – DisgruntledGoat Apr 9 '12 at 11:05
And it's the latest iOS, v5.1. – DisgruntledGoat Apr 9 '12 at 11:06

You could try to perform a network reset on the iPhone (not just "forget network") and a firmware upgrade on the Netgear. If I remember correctly, the DGN1000 has a builtin upgrader tool on the web interface.

share|improve this answer
up vote 0 down vote accepted

I will answer this question myself since none of the advice here worked. I searched for days and tried everything under the sun with no luck whatsoever. In the end I just took the router back and exchanged it for a different one (Belkin).

I know this is a bad answer, but that's what happened and everything works fine now.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .