Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently migrating to openbox without gnome session. In unity i can use the vendor keys to set the screen brightness, but in openbox I'm on my own.

  • /sys/class/backlight/acpi_video0/brightness works fine, the problem is that I need sudo to set the brightness and that wouldn't work with keyboard mappings.
  • xbacklight -get/set doesn't do or output anything.
  • I don't really want to use xrandr --brightness.

Are there any other options or a way to fix the problems with xbacklight or acpi_video0 ?

share|improve this question
up vote 2 down vote accepted

My solution was to add the following line to etc/rc.local:

chmod a+w /proc/acpi/video/VID/LCD/brightness

I don't know if permissions can also be changed in the /sys filesystem.

share|improve this answer
    
Doesn't feel that good to mess around with permissions there but the show must go on. Thanks eldering. – zls Apr 8 '12 at 12:27
    
/proc/acpi is obsolete, and recent kernel versions disable it by default. – grawity Apr 8 '12 at 12:41

The command GNOME and Unity use is:

pkexec /usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 5

It does not require a GNOME session to be running, just PolicyKit – which is almost always present in Ubuntu.


You can use ordinary sudo in key bindings; it can be configured to run certain commands without a password by editing the sudoers file. For example:

zls     ALL=(root) NOPASSWD: /usr/lib/gnome-settings-daemon/gsd-backlight-helper

or

zls     ALL=(root) NOPASSWD: /usr/local/bin/my-custom-brightness-script
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .