Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It's been one month I'm trying to install the Nokogiri gem on Fedora 16 to run a friend's Rails project.

I installed Ruby with RVM. Using gem install nokogiri returns

libxslt is missing. please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.

So I tried installing libxslt-devel with yum and it didn't work. So I used rvm reinstall to recompile ruby with xslt path given and it still doesn't work.

Then I tried installing ruby-xslt but it doesn't work because I'm using RVM.

How do I solve this awkward problem ?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Just install appropriate RVM package.

rvm pkg install libxslt
share|improve this answer
    
I tried it and it didn't work. –  Skydreamer May 17 '12 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.