Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

About 8 months ago my Windows XP laptop stopped being able to see FAT32 external drives when I plug them in... mostly. I will explain...

It happens with all my FAT32 drives, whether they be unpowered external hard drives, powered external hard drives, SDHC cards plugged directly into the machine's card reader, or SDHC cards plugged in via a separate USB card reader.

All of these drives/cards used to work fine on this machine. They all stopped working at about the same time.

NTFS volumes are not affected. If I plug in NTFS external drives they are recognized right away. I even have one external drive with two partitions on it, one is NTFS which is recognized, the other is FAT32, which is not recognized.

If I attach a FAT32 drive, then reboot, then the drive almost always becomes visible to the machine after the reboot.

Sometimes I can plug in a FAT32 drive and it works right away. Not often though. I'd say I get lucky more often with SDHC cards than hard drives. I'm developing a theory that I only get lucky with hard drives if I'm running Acronis Disk Director when I plug them in, though that usually doesn't work either - I need more data here, this may be a red herring. Getting lucky with a hard drive is really rare, usually I have to reboot.

When a FAT32 is recognized, either because I got lucky or because I rebooted, I can almost never safely disconnect it. It tells me "The device 'Generic volume' cannot be stopped right now. Try stopping the device again later". I can't seem to get around this. IIRC, I've tried closing every open window, and still no luck. Since I care about my data usually the only way to disconnect a FAT32 drive is to shut down the machine. As you can imagine, two reboots just to read a drive is getting pretty old...

When the machine fails to see a FAT32 drive it usually comes up with the appropriate drive letter and the words "Local Disk" in Windows Explorer instead of the correct partition name. If I click on it I get "J:\ is not accessible. The parameter is incorrect."

Before this problem arose I always clicked the "safely remove" button for everything, including SDHC cards where I think it's not necessary. I've known for a long time that this is the correct procedure for hard drives, so I don't think failing to do this was the cause of this problem (before someone asks :)

Any answers or suggestions most welcome.

share|improve this question
Are we to assume these fat32 drives work ok on other XP machines? – Moab Apr 8 '12 at 22:55
@Moab I just took a FAT32 powered external drive that was failing on the laptop in question and plugged it into my old XP tower and it worked fine first time. I'm sorry I don't have more data - I haven't done this before because I'm usually attaching drives to the laptop to copy large amounts of data between disks local to the laptop. – Rob_before_edits Apr 8 '12 at 23:12
If you have a XP install CD that is integrated with SP3 (should match whatever SP you currently have installed, I assume SP3), try running a System File – Moab Apr 8 '12 at 23:27
@Moab Unfortunately the machine is SP3 but the install disk that came with it is SP2. – Rob_before_edits Apr 8 '12 at 23:47
You can slipstream SP3 into a new disc using your old one and a copy of – Moab Apr 8 '12 at 23:49
up vote 3 down vote accepted

The problem I describe above appears to have been associated with, if not directly caused by, the contents of a couple of registry keys used by both Acronis Disk Director (Version 10.0 for which I paid) and Acronis True Image WD Edition (Version 11.0, which was free) which I had installed.

A big clue came from this Microsoft Support article which, under the "Let me fix it myself" subtitle, describes certain registry keys which if corrupt can cause hard drives to be unseen. Looking at these registry keys I found they contained the snapman driver, which Google revealed to be an Acronis product. This tied in with my Acronis observation mentioned in my question and the driver details visible under Device Manager->disk drives->(the disk in question)->Properties->Driver->Driver Details which showed snapman.sys as one of the drivers. I therefore deleted the registry keys as recommended by the Microsoft article (actually only the UpperFilters, I didn't have a LowerFilters), and also removed the snapman entry from the other keys in which it appeared following this Acronis Knowledge Base article Figuring this probably broke my Acronis products I then uninstalled both of them using Control Panel->Add or Remove Programs. With all of these steps completed my drive attachment/removal problem was fixed : I successfully attached a FAT32 mass storage device and safely removed it four times in a row. I then reinstalled Acronis Disk Director (the Complete program, for All Users) which put the snapman driver references back into the registry keys. Then I successfully attached and safely removed the same FAT32 mass storage device another three times. I've decided not to risk reinstalling Acronis True Image. I suspect it may install its own version of the snapman driver, which may conflict with Disk Director's, and make further changes to the registry keys. It can be run from a bootable disk, and since I only run it occasionally that's good enough for me.

I say associated rather than caused above because I'm pretty sure I had both Acronis products installed and was running them off and on for many months without any drive attachment/removal problems. While trying to solve this problem I Googled the search term '"is not accessible" "the parameter is incorrect"' without the single quotes and read the first 50 web pages returned. A theme that cropped up a few times was people facing this problem after having changed drive letters. This was interesting because I suspect that my own problem dates back to last July or so when I was repartitioning and changing drive letters on my backup drives. I was doing this using Acronis Disk Director. So I speculate that changing drive letters may somehow be involved in triggering this problem. This is speculation, but it does suggest another solution to the problem which might work, perhaps even for people who are not running Acronis, which is to do a system restore to the day before you were changing drive letters. I tried to do this myself before I zeroed in on the registry keys, but unfortunately my backups/restore points didn't go back far enough.

EDIT : I find I still have a problem with my machine's inbuilt card reader. When I insert an SDHC card (formatted FAT32) I can see it properly, but I cannot safely remove it. However, if I use a $2 card reader to turn the SDHC card into a USB drive then it attaches and safely removes without a problem.

share|improve this answer
@Googlers who might reach here in the future: Manually mounting the drive may possibly work:… – user13267 Dec 14 '12 at 2:00

The issue is that XP doesn't directly support exFAT. Support for exFAT was introduced with Vista SP1 and is included with Windows 7. You can add support for exFAT in XP and Server 2003 by installing an update available here:

Description of the exFAT file system driver update package

XP will not format a volume over 32GB as FAT32 although some third party tools do support this.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .