Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to mount a FTP as filesystem in debian using curlftpfs. What I get after running

curlftpfs -o allow_other username:password@ftp.server.com /mnt/myftp/

is just:

fuse: failed to open /dev/fuse: Permission denied

even when run as root. What am I doing wrong? (curlftpfs is in version curlftpfs 0.9.2 libcurl/7.21.0 fuse/2.8)

edit:

When I write ls -lah /dev/fuse, I see

crw-rw---- 1 root fuse 10, 229 Apr 9 00:34 /dev/fuse

...but even when I add both myself and user root to group fuse, neither me (as a user) or user root can mount ftp, I still see

fuse: failed to open /dev/fuse: Permission denied

edit2: Even if I write this fairly insecure and crazy line:

sudo chmod a+rwx /dev/fuse

I still get the permission denied message. Which permissions could be denied?

edit3:

I forgot to mention I am on VPS with OpenVZ. I thought that there is no issue with this, but apparently, there is! I am adding the resolution as the answer.

share|improve this question

2 Answers 2

It is an issue in OpenVZ. One can't mount FUSE systems (curlftpfs uses fuse) from inside an OpenVZ system.

There is a how-to for OpenVZ here : http://wiki.openvz.org/FUSE , but one needs an access to the outside machine. I don't have that.

share|improve this answer

Use sudo command it worked for me.

$sudo curlftpfs -o allow_other username:password@ftp.server.com /mnt/myftp/
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.