Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I decided to try this suggestion to install Android x86 on Virtual Box. I'm following those steps and I'm at #4. I used the android-x86-4.0-RC1-amd_brazos.iso (because I have a ThinkPad that this might be compatible with and it seemed as good as any of the other choices...)

I'm getting an endless series of errors:

.[numbers] VFS: could not find a valid v7 on sda.
.[numbers] VFS: could not find a valid v7 on sda.
repeating...

For storage, I made a VDI image sized at 4.0 GB (dynamically allocated) attached on SATA Port 0.

Background and more details:

I'm running Kubuntu 12.04. I installed VirtualBox 4.1.12 after adding deb http://download.virtualbox.org/virtualbox/debian precise contrib to my sources.

EDIT: Now I'm wondering if I installed the right package. I verified that I'm running 4.1.12. But I installed it with apt-get install virtualbox instead of the recommended apt-get install virtualbox-4.1. I checked just now and see this:

apt-cache search virtualbox
virtualbox - x86 virtualization solution - base binaries
virtualbox-4.1 - Oracle VM VirtualBox

But when I run VirtualBox, I get the Oracle VM VirtualBox Manager version 4.1.12, so I think I'm OK.

I did see one minor issue (possibly related to this question) when installing VB, but in my case I don't think it is actually an error at all:

* No suitable module for running kernel found [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.

VirtualBox installed and seems to be running fine. I just can't get the ISO image to install. The error is as shown above.

share|improve this question
up vote 1 down vote accepted

I installed a different image: android-x86-4.0-RC1-asus_laptop.iso

It worked. I'm not sure if the brazos image incompatible with the VM I set up or there was some other issue. But it is working with this image.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .