Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Dell 4100 system (built in 2001) has a AGP. Should I be concerned that a newer AGP graphic card will not work in this older system?

Here are two AGP graphic cards sold at our local Microcenter

  1. Radeon HD 3650 512MB DDR2 AGP Graphics Card ($100)
  2. Radeon 9550 256MB DDR AGP 4X/8X Graphics Card ($70)

Will these work in my system? It mentions a lot of Product Specifications that I am not sure if they are system specific (i.e. Interface, Memory Bus, etc.).

The 3650 also mentions that a PCI-E 6-pin power connector is needed. How do I know if I have this power connector?

I just upgraded the Dell 4100 to use Windows 7 RTM and the card in it now does not support Aero along with it producing choppy video playback using Windows Media Player.

I am mainly looking at just getting this system to play the Video back with it not being choppy. Will these two graphics work to do that (If they both will I will buy the cheaper one.)

The Dell 4100 system specifications are:

  • 1 ghz
  • 512 mb RAM
  • 1 agp slots, multiple PCI slots

Here is another tid bit. I read that Windows 7 uses DirectX (or Direct3D) 10.1 and the 3650 mentioned above supports 10.1, where the 9550 supports only 9.0.

Thanks in advance.

share|improve this question
add comment

1 Answer

If the 3650 needs a PCI-E 6 pin power adapter, I would bet your Power Supply doesn't have it. There are adapters for this, however. (link)

I'm pretty sure with AGP that if a card is AGP and you have an AGP slot, you should be fine, as long as the x# matches with your system's specs. (don't quote me, though :) )

But, check with Micro Center's return policy. If it doesn't work, you may be able to return it. Also, definitely check with a sales associate at the store and tell them about your machine. They will know for sure if your machine can handle it.

As for DirectX, yes, Windows 7 uses DX 10 and eventually DX 11. By no means is this necessary (especially for your older machine). There are only a handful of games that even support DX 10 at this point, so I wouldn't worry too much about it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.