Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to access my Mac from a Windows 7 computer, I fail with the infamous error 86 incorrect password.

Now this appears to be a well-known problem with countless threads on the internet giving as many "solutions" as there are discussion threads about it (mostly ranging from installing third-party commercial samba servers, to switching to some other protocol, to compiling a plain-vanilla Samba installation - the latter which I will probably do when I give up this :) )

I am stubborn, and I believe there must be some problem here that can be solved or worked around, but there is surprisingly little detail about this problem. It appears to have something to do with a mismatch of authentication methods. Trying to run samba in debug mode:

sudo /usr/sbin/smbd -debug -stdout

gets me this output when trying to access it from Win 7

...
smb1_dispatch_one [smb_dispatch.cpp:377] dispatching SMB_COM_SESSION_SETUP_ANDX
smb1_dispatch_session_setup [session_setup.cpp:261] FIXME erase existing sessions
log_gss_error [gssapi_mechanism.cpp:97] gssapi: gss-code:  Miscellaneous failure (see text)
log_gss_error [gssapi_mechanism.cpp:113] gssapi: mech-code: unknown mech-code 22 for mech unknown

What is the problem here, and how do I fix it?

share|improve this question

migrated from serverfault.com Apr 9 '12 at 11:26

This question came from our site for system and network administrators.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.