Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to specify a tab to be four spaces in Text Wrangler by checking "Preferences" -> "Editor Defaults" -> "Auto-expand tabs."

However, tabs still comprise of tab characters with each tab having the width of 4 spaces.

share|improve this question
try closing, then re-opening the program – wizlog Apr 9 '12 at 19:18
It's still not working for some reason after reopening Text Wrangler. I know it's not working because I cannot move my cursor through the tab as if it were spaces. Also, after opening the document in vim, I cannot do this either. – David Faux Apr 9 '12 at 19:29
You created that file with no auto-expand. TextWrangler remembers the state of this document. The preferences only apply to new files. You need to set auto-expand for this file in the file's toolbar (click on the T-icon to see a dropdown list with this option). – what Jan 6 '14 at 20:16
The last comment worked for me. TextStrangler remembering settings per file must be the worst feature in history... – Jonny Jul 21 '14 at 3:47

1 Answer 1

up vote 2 down vote accepted

If it's a special type of document, you might try Preferences > Languages. Select the language the document content is, then go to Options... > Editing and select "Auto-expand tabs", then click "Save."

share|improve this answer
This didn't work for Python. Version 4.5.9 – Jonny Jul 21 '14 at 3:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.