Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install Xorg on my Arch Linux VM, what I have done so far:

  • edited /etc/pacman.d/mirrorlist and uncommented my country mirror
  • dhcpcd eth0
  • pacman -Syy
  • pacman -S xorg-server, which also started a few updates
  • a few errors led me to delete /usr/bin/tzselect, /usr/sbin/zdump and /usr/sbin/zic
  • continued with pacman -S xorg-server

Finally it looks like it's installing, but in the end I got a lot of errors:

...
xorg-server: key "946...." is unknown
key "946..." could not be looked up remotely
failed to commit transaction (invalid or corrupted package (PGP signature))

Update 2012-04-09 21:17

Just tried to run pacman -S sudo and I saw all the errors, and it indicates to run pacman-key --init, hoping this will solve the problem.

Edit

That took a lot of time, but I still get errors.

Update 2012-04-11 01:55

I edited /etc/pacman.conf and set up SigLevel = Never

share|improve this question
add comment

3 Answers

As you've figured out, its a PGP signature error. Since spring of 2012, pacman (the Arch Linux package manager) requires packages to be signed. You can either disable the signature requirement (not recommended) or run the following:

pacman-key --init

The above command may take a while. If you can, in another terminal run ls -R / a couple of times to help generate randomness. Once the init command is done, you need to provide pacman with the list of the keys which are accepted (this step is critical).

pacman-key --populate archlinux

This command may ask you to sign the keys. You'll want to say yes to all of them.

Source: pacman-key article on the Arch Wiki

share|improve this answer
add comment

Just tried to run pacman -S sudo and i saw all the errors, and it indicates to run pacman-key --init, hoping this solves the problem.

Edit: This took a lot of time, but I still get errors.

share|improve this answer
add comment

I edited /etc/pacman.conf and set up SigLevel = Never

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.