Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Is there any way to disable screen shortcuts such as Ctrl+Alt+[F1..F4] in Windows 7?

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007 Oct 28 at 15:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Do you remember where did you enabled it? Im asking because it is not enabled by default on my Windows 7. Ctrl+alt+F1 or F2 resulted in nothing here... –  Diogo Apr 10 '12 at 12:40
1  
It will result - if you add second monitor! And sometimes it makes me crazy. :( Cause I have same hotkeys in virtualbox, that I use often. –  Nikolay Fominyh Apr 10 '12 at 12:44
    
Hmm, now I understand you... But in this case wouldn't be better to change Virtualbox's hotkeys? –  Diogo Apr 10 '12 at 12:45
1  
Did you install some kind of software like ultramon or desktops from sysinternals? I have multiple screens and my ctrl+alt+f1-f4 do nothing. –  Phillip R. Apr 10 '12 at 12:54
    
@DiogoRocha, yep, that's the answer I hear from windows users. "It confuses you to do something? Don't do something!".. –  Nikolay Fominyh Apr 12 '12 at 9:26

2 Answers 2

up vote 1 down vote accepted

There is no native way to disable hotkeys in Windows 7. (By the way: The shortcuts you mention are not default hotkeys by Windows 7.)

You can however use AutoHotkey to disable almost any keyboard shortcut. There are other utilities for this, but AutoHotkey is my weapon of choice.

You can disable the hotkeys mentioned here with the following code:

^!F1::return ; disables Ctrl-Alt-F1
^!F2::return ; disables Ctrl-Alt-F2
^!F3::return ; disables Ctrl-Alt-F3
^!F4::return ; disables Ctrl-Alt-F4

Just paste the code into an AutoHotkey script that you launch at startup and the keys will be permanently disabled.

If you want to reassign the hotkeys to something else, you can do as follows:

^!F1::Send ^{Enter] ; sends Control-Enter when pressing Ctrl-Alt-F1
^!F2::some boilerplate text ; types phrases

I happen to have provided an answer to a similar question: How do you disable hotkeys in Internet Explorer 9?

share|improve this answer

Similar thing happened to me. I happen to have an Intel display card.

There's an Intel Graphics and Media Control Panel that allows "Hot Key Functionality" to change various aspects of the display. One of the default hot keys is Ctrl-Alt-F1.

  • To access that control panel right-click on your desktop and choose "Graphics Properties..."
  • On the left select "Options and Support".
  • On the right you'll see those hotkeys.
  • You can disable them by unchecking the Enable checkbox at the top.
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.