Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I double-click to open an executable on the desktop (.exe, .bat, etc.), or a shortcut on the desktop that points to an executable, the "Security Warning" pops up and asks me "Are you really sure you want to open that? Stuff from the Internet is dangerous!"

I don't usually mind this warning and don't want to disable it globally, but now I'm getting it for any executable on the desktop, even ones that I didn't download from the Web and don't have the Mark of the Web alternate data stream. (That is, streams -d * shouldn't and doesn't help.)

This started fairly recently, but I can't really point to anything I did that triggered it. It only occurs in one user account on the machine; the other account doesn't have this problem. Running System Restore didn't help.

How can I fix the problem and make the pop-up warning appear only when it's supposed to?

share|improve this question
    
This sounds like a virus its self... did you download the 'Security Warning' software or something? –  ekaj Apr 10 '12 at 20:53
    
Maybe, but I hope I'm not that stupid :P Besides, I have a decent real antivirus app (Microsoft Forefront). –  Michael Ratanapintha Apr 10 '12 at 21:03
    
Does this come with all Windows 7 Distros? Because when I installed this one, I didn't have to turn such a feature off.. I've seen the 'This publisher cannot be verified one', but not this. –  ekaj Apr 11 '12 at 0:53
add comment

1 Answer

up vote 1 down vote accepted

I snatched the answer from Microsoft Technet site (which somehow resembles very much with stack overflow sites, hmmmm....):

C:\>ICACLS "C:\Users\<YOUR_USERNAME>\Desktop" /Setintegritylevel (OI)(CI)M
share|improve this answer
    
Hm, forcing the mandatory integrity level of the desktop folder to Medium seems to have worked! Strange, though, nobody ever mucks with that setting, so it should usually be Medium by default. –  Michael Ratanapintha Apr 11 '12 at 1:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.