Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I've run into a very strange problem with my home wireless network. Previously, at seemingly random times, the router seemed to disconnect all wireless hosts and cause all of the wired hosts to have a "limited connection" according to windows. In order to fix this, I had to unplug all of the wired hosts from the router, unplug the modem from the router, and power cycle the router. This seemed to solve the problem for a while until the exact same thing happened a day later and I had to go through the same process again.

That's where I noticed something weird happening. There was one wireless host (a Windows Vista laptop) that seemed to be causing the router to disconnect the other hosts whenever it connected. When this happened, only that laptop was able to use the wireless from the router. When this happened, I disconnected it from the wireless (by disabling the wireless adapter) then reconnected it (by re-enabling it) and now it, like the other hosts, couldn't connect.

I've never really seen anything this strange happen on our network before. So, I restored the router to factory settings and the problem seems to have vanished except one crucial problem. There's another host (a Windows 7 laptop) that was perfectly able to connect before all of the router issues and even in between the crashing and power-cycling events but now says its connected and says it's able to reach the Internet, but all requests time out. In any browser I've tried, the tab says connecting to [site]... for a solid minute and then tells me the request timed out. When I try to ping google.com in cmd it also says request timed out.

In frustration, I booted into a dual-boot Ubuntu installation on the Windows 7 host and the connection works fine, to my surprise, as ubuntu is where I am now typing this rather long question.

  • I haven't looked through the event log in windows but will post anything I find in an edit
  • I haven't tried connecting (in Windows 7) to any other wireless network, since
  • The fact that it works in Ubuntu suggests its Windows and not the router but I didn't change any wireless settings in windows before it being able to reach the Internet and not.

Does anyone have any clue what could have happened. I opened to buying another router as this one is almost a year old :) but I would like to know whats going on here.

Thanks in Advance!

P.S. Sorry for how long my question is, I'm a little anxious (:

Update:

So, I've got a bit more info if it will help:

  • I'm able to access local hosts from the Windows 7 laptop (like the router and a fileserver I have on the network)
  • I've cleared the arp tables in Windows 7 but before I did their didn't appear to be anything wrong with them beforehand.
  • In the windows event logs, there are a few strange DNS-related warnings:

Level: Warning

Date and Time: At and after booting into Windows after Ubuntu

Source: DNS Client Events

Event ID: 1014

Message:

Name resolution for the name 6to4.ipv6.microsoft.com timed out after none of the configured DNS servers responded.

The only thing that differed between all of these errors was the host being resolved:

  • h-app02-06.hamachi.cc
  • crl.microsoft.com
  • accounts.google.com
  • clients4.google.com
  • www.google.com
  • cr-tools.clients.google.com
  • 158.talkgadget.google.com

I'll try changing the default DNS servers on the router to Google public dns but all the other hosts work on the default dns so...

share|improve this question

2 Answers 2

Does it have anything to do with arp table? What about trying to use static IP-MAC mapping in the router? Some virus can really mess up your network by arp spoofing. At least it can explain why Ubuntu works fine.

share|improve this answer
    
So, I tried running "arp -d *" and it ran sucessfully (when I ran it as administrator but didn't fix the problem, still not internet). I already had that host fixed to an IP along with another host for port forwarding purposes on the router. When I removed the static IP and reconnected, it was still a no-go. –  Brandon Apr 10 '12 at 23:35

Make sure you only have one DHCP server. If you have a separate modem, router, or wireless basestation, each could be running its own DHCP. Which ever device is closest to the physical uplink should be the DHCP server and all others should be in bridge mode. Also check all of your computers to make sure they are not running DHCP or any form of "Internet Sharing".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.