Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 3 computers with WinXP x86, and 3 Cisco 1800 series routers. I'm trying to create a workgroup so that the 3 computers can share files with eachother. They can ping eachother (without any internet connection), and the routers setup is correctly configured (with interfaces, ip adresses, and ports). But none of the computers can see eachother, even though they are on the same network.

My first question would be - can it be done the way it is currently configured - and, if yes, how, or can anyone point me in the right direction?

share|improve this question

To connect three computers you need only one Ethernet switch and no routers.

Windows XP computers will "see" each other if they are all connected to the same LAN segment (same subnet) and configured with the same workgroup name and you wait long enough (10-15 minutes).

Configuration options include

  • auto
  • static (manual)
  • dynamic (let one router act as a DHCP server).

I'm not sure why you have three routers

  • are the three computers in separate buildings?
  • are you attempting to create a VPN over the Internet?

In workgroup mode I believe Windows filesharing depends in part on broadcasts, these broadcasts are restricted to the local LAN segment. Therefore it is simplest to have all three computers in one LAN segment with a common IP subnet.

Update See:

share|improve this answer
It's a part of a extra-task in a task I have been assigned for lecturing. It works fine if I connect 2 computers to one of the routers, but not with them on seperate routers - which is a necessity – Silvera Apr 11 '12 at 11:07
@Silvera: Workgroup based browsing doesn't work across routers. People normally use (multiple) domain controllers for this. However you can access Workgroup-based resources explicitly (try start run \\pcdnsname or start run \\pcipaddress). See references in updated answer – RedGrittyBrick Apr 11 '12 at 12:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .