Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How can I find out about an unknown file extension?

What is the .i3d file extension? How can I read/edit such files?

(Googling isn't helping much, because "3d" is a common term.)


The file comes from an iOS App Draw Somethin, and it almost certainly isn't a 3d image file.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Oliver Salzburg, Mokubai, studiohack May 6 '12 at 4:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

A file name extension does not dictate content, it could be arbitrary. – Oliver Salzburg Apr 11 '12 at 23:00
have you tried opening it with a text editor? is it binary or text? – Baarn Apr 11 '12 at 23:04

Well I tried google and dug up something

Three-dimensional texture file created by Houdini, a professional modeling and rendering program; can store arbitrary volumetric data in 3D space; often used for storing clouds or smoke.

search term was .i3d file

Actually seems that more programs, like maya or blender, are able to handle these kind of files.

btw: If you want to search for a specific phase and don't want google to autocorrect it you can put it between quotes, too. eg: "i3d"

share|improve this answer

Well, it would help to mention what that file is from, other than an 'ios app'. I'd try opening it in a text editor. I'd also try to make use of trid, which makes an informed guess of what a file is, and the file command in linux, which compares it against magic numbers. Trid also has a online version and a filetype index

If all else fails, you may want to consider poking around a bit with a hex editor. You could then google or otherwise look up the file header.

share|improve this answer
Trid doesn't help. Probably proprietary. – Moshe Apr 22 '12 at 8:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.