Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed the Windows 8 consumer preview and all working fine, with the exception of the communication apps (mail, calendar & people).

The apps were working during initial installation process, but at some point ceased to operate. The message I receive when launching is "Mail can't open", "Calendar can't open" and "People can't open". I also note that the Weather app doesn't work, and simply hangs on loading screen.

I have attempted install numerous times, but cannot establish the point at which the apps stop working. I assume it probably relates to one of the updates, but that is only a guess.

Has anyone else experienced this? Does anyone have any ideas on resolution?

Many thanks.

share|improve this question
Betting some service isn't started but I can't think of which one would be the culprit. Might look in services.msc though. – LawrenceC May 8 '12 at 17:01

I had the same problem but I resolved it, I found that the antivirus Firewall was the cause, it blocks all metro apps to connect to the network, disable it or change the Firewall rules.

share|improve this answer
For me, it was Avast antivirus's real time protection. Solution:… – Imre Kelényi Oct 22 '12 at 15:09

Metro apps won't start if the screen resolution is less than 1024x768, is this your case?

It happened to me when I was running Win8 in Virtualbox

share|improve this answer
Screen resolution is well above 1024x768. The issue isn't that nothing happens, or the similarly reported white screen issue. I get a message stating "Mail can't open", for example. – Carnubarnagra Apr 12 '12 at 18:16
In that case I never experienced that... – Magnetic_dud Apr 13 '12 at 8:58
Thanks for trying to help. – Carnubarnagra Apr 13 '12 at 20:58

I had the same issue as well (on release preview). A first hint gave the SkyDrive app that failed as well, but mentioning that it failed to login for some reason (0x8009000B). What fixed the issue for me:

  • Settings > Change PC Settings > Users > Switch to a local account

Then when starting the calendar, it asked me to sign in and worked fine again. And it still worked after changing the account back to a Microsoft/Live account and verifying it.

share|improve this answer

Update: SOLVED!

The problem occurs if you tweak your background colors using a tool or manually. Restore all the default registry entries or default colors using the tool and poof! Problem is gone....

Hope this helps, Phew!

This's not exactly an answer but I've the very same problem. And I've been looking for an answer and have tried the following.

  1. Uninstall, re-install - doesn't fix.
  2. Create new user on Consumer preview and try these apps/ re-install there. - doesn't fix so 1 thing is for certain, the problem is not within the "Users or Users/name/appdata"

  3. I replace all metro app files in my PC (taking ownership) for another working fresh Consumer Preview install on another PC (where the people/msgs/cal/email app works fine). - Still doesn't fix. so the program files ain't the culprit either.

  4. That leaves 2 things - the windows folder (the metro framework) and the registry. Now the problem can't be with the metro framework because other apps work fine and the msgs/people/mail/cal app can be uninstalled which means it is not coded into the system.

So that leaves the registry, which should be the culprit. I have yet to try messing with the registry to solve this. Will edit this answer if I do find something.

Refresh apparently solves this but I don't want to be re-installing all my desktop apps.

share|improve this answer

protected by Community Oct 22 '12 at 20:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.