Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The audio output of my MacBookPro4 with Snow Leopard is very noisy. Right after I start some sound player software, a loud white noise starts on the standard audio output (the jack for the headphones) and it can be heard during the whole audio playback, and some time after the audio stops (I guess until the audio player software switches off the audio device).

I can confirm that not my sound files neither my headphones are noisy (I played the same files with the same headphones on an other computer and it's ok) but the noise comes from somewhere the OS / hardware.

Did somebody experienced similar thing? Can something be down from software? I would prefer to identify to source of the noise and eliminate it instead of installing some noise filter software. Or if it is a hw problem, could you suggest me some solution?

share|improve this question
    
Does this also happen when you use the MBP speakers, or is it just with the head phones? –  zk. May 3 '12 at 13:35
    
Do you by any change have a mobile internet modem or any similar device connected to the laptop? Even a nearby cell phone can cause an annoying noise. –  Dennis May 3 '12 at 17:07
    
@zk. As far as I can understand only with the head phones. –  MrTJ May 4 '12 at 7:46
    
@Dennis no, I use wired Internet and it is not the typical scattered mobile phone interference sound but a continuous white noise. –  MrTJ May 4 '12 at 7:48
    
@MrTJ: Well, it was worth a shot. Unlike the cell phone, the noise caused my a mobile internet modem is continuous. Was driving me crazy until I finally figured it out... –  Dennis May 4 '12 at 11:43
show 1 more comment

1 Answer

up vote 3 down vote accepted

Well I will answer the question myself as the problem is solved: it was caused by a KVM between the MacBookPro and my earphones. It's quite stupid from me that I forgot about it but in the mess on my table I really did not realize that the audio port is attached to it. However it is still strange that the audio port of a windows pc attached to the same KVM did not produce any similar noise, maybe the cable between the KVM and the macbook collected it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.