Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a problem with iTunes where syncing my iPhone ends up seeming to basically finish, but it says "Waiting for items to copy" after everything else, and just stays there for... well, a very long time, if I let it. I'm not sure this is always the case, but at the moment, it's doing this while "Syncing Genius Data to [my iPhone] (Step 8 of 8)".

If I click the little x in iTunes, it then gets stuck on "Canceling sync", for an equally indefinite sort of period.

If I simply unplug the phone, everything seems to be synced and happy, but the next time I sync, it happens again.

I presume this is a bug of some sort on Apple's part, but it seems like people have found workarounds. I'm just having trouble tracking one down that

  • is well described enough that I can actually follow it
  • has enough detail that I can do it without losing data, i.e. tells me path names that I might want to copy first, or the like, before telling me to remove something. Note: see also the first point — I can't remove it if it's telling me to remove something that I don't know where it is!, and
  • otherwise seems sane
share|improve this question
up vote 3 down vote accepted

I ran into the exact same issue. after three failed syncs, I did a factory reset of my ipod touch, rebooted the computer, checked for an update from Apple. There was actually an update (I'm not sure what the version number was) and after installing the update the issue was corrected.

share|improve this answer
Had the same thing happen on my iPhone 3GS, it wasn't until there was a large OS update that it was fixed. My next step would've been a factory reset (which the iOS ?5? install kindof does) – HaydnWVN Apr 12 '12 at 14:03
Hmm, weird. I just installed the iOS 5.1 update a bit ago, and I'm pretty sure my next sync still failed after this, but maybe that was just because my iPhone had still been plugged in? I just tried again, and it resolved itself. So I guess maybe this did the trick! So, taking this answer to be "If an update is available, install it." Of course, I had been wanting to get a "successful" sync to happen first... that's why I'd waited this long in the first place! Ah well. :) – lindes Apr 12 '12 at 14:25
I totally understand that reasoning, it was why I initially attempted to sync over and over despite the sync hanging at "waiting for items to copy". Oh well, at least it's resolved. – tjd802 Apr 12 '12 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .