Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 7 Ultimate x64 PC has a strange networking issue. When I resume from sleep, no web pages will load (other programs such as Hamachi VPN are also unable to locate their servers). If I use Google Chrome, it says that DNS lookups are failing. However, if I then open a command window us use NSLOOKUP to perform lookups for the web pages that just failed, the lookups appear to be working correctly. So the command prompt is able to perform lookups, while other applications such as web browsers are not.

I can clear this problem by disabling then enabling the network adapter in 'Network and Sharing Center'. After doing this, everything works again. It's a pain to have to do that each time I resume from sleep, though.

Anyone know the cause for this, or have a suggestion for how to troubleshoot it?

share|improve this question
    
Could try a different network driver maybe? Does this occur using all browsers or just with Chrome? –  jmreicha Apr 12 '12 at 18:05
    
Its not specific to browsers, that just happens to be the most obvious impact. For example, the Hamachi VPN client also has problems. Its an intel NIC and Intel only offers one driver. I don't even know where I'd get a different one. –  Tim Long Apr 12 '12 at 22:41
    
@TimLong Have you been able to resolve this issue? I started encountering the exact same behavior earlier this week after i changed DNS setup on my local area network. What i did was install Windows Server 2008 R2 as a domain controller with the DNS server role and joined some computers to the domain. The problem seems to be limited to just one computer (a member of the domain) connected to the network via an ethernet cable. LAN connections still work properly, but any WAN connections do not, even though names are resolved properly within the LAN and WAN. –  Kallja Aug 12 '12 at 17:06

6 Answers 6

Check whether you have multiple DNS servers listed. If you do, make sure all of them are valid. Having a mix of good and bad DNS servers can cause very inconsistent DNS behavior.

If you are getting the DNS server from a DHCP server, check whether the DHCP server is configured with multiple DNS and whether they are all correct.

share|improve this answer
    
That's an odd situation isn't it. The point of multiple DNS servers is for redundancy, i.e. if one of them is bad, the others take over. So you're suggesting that the feature doesn't work in the presence of a bad DNS server, which renders multiple DNS servers pointless. –  Tim Long Aug 12 '12 at 21:08
    
The point of multiple DNS servers is only to have a fallback in the rare case that one of them is briefly inaccessible and/or to distribute the load amongst multiple systems. It is still assumed that the systems listed as DNS servers actually are DNS servers, that they will all work most of the time, and that they will not return incorrect information. When those assumptions turn out to be incorrect (whether due to servers moving or just typos), bad things can happen. –  Seth Noble Aug 13 '12 at 18:23

If you have hamachi, maybe is the culprit, after i uninstalled it all worked again, another alternative is try to enable and disable the hamachi network adapter

share|improve this answer

Change the settings in advanced power profile properties so your LAN adapter doesn't go to sleep/power down.

This can be disabled regardless of your network adapter.

Source: Microsoft Technet

Configuring power management using the user interface

To turn power management features on or off

  1. Open Network and Sharing Center (click the Start button, type Network and Sharing in the Start Search box, and press Enter).

  2. Click the Change adapter settings link in the upper left of the navigation pane.

  3. Right click the network connection you want to enable/disable power management support on and click Properties.

  4. Click Configure.

  5. On the Power Management tab, check or clear the Allow the computer to turn off this device to save power check box.

    When checked, power management is enabled on the network adapter.

    When cleared, power management is disabled on the network adapter.

share|improve this answer
    
If he has integrated NIC, nothing can be done. –  HackToHell Apr 12 '12 at 14:21
1  
You can still change the power options for it as that's Windows based not adaptor based. See my amended answer above with Microsoft technet article. –  HaydnWVN Apr 17 '12 at 10:04

Same in Windows 8 and 8.1: After sleep the Windows DNS client does not work properly. Open the service control, look for DNS client and restart it. DNS lookup should work again without restarting the machine.

share|improve this answer

reset network device

resetting "Realtek PCIe GBE Family Controller" fix it for me

devcon restart "PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09"
PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09\4&21A1C3AE&0&00E5: Restarted
1 device(s) restarted.

uninstall realtek network driver doesn't fix it

uninstalling the realtek network driver doesn't fix it for me. dns lookup is still often broken when i return from sleep

test

before reset nslookup takes several seconds

nslookup google.com
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  8.8.8.8

DNS request timed out.
    timeout was 2 seconds.
Name:    google.com
Address:  2a00:1450:400f:804::200e

after reset it returns instantly

nslookup google.com
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    google.com
Addresses:  2a00:1450:400f:804::200e
          216.58.209.142

my dns server is 8.8.8.8 instead of my isp's because i changed it in case that was the problem. which it wasn't

netsh interface ipv4 add dnsserver "Local Area Connection" address=8.8.8.8

after the test i reset the dns server and nslookup still works

netsh interface ip set dns "Local Area Connection" dhcp

before reset dhcp renew timeout

C:\Users\User>ipconfig /release & ipconfig /renew

Windows IP Configuration


Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::a1cf:1ddf:5c50:191%8
   Autoconfiguration IPv4 Address. . : 169.254.1.145
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::3dae:5a21:fdc0:e49e%6
   IPv4 Address. . . . . . . . . . . : 192.168.217.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{1D0B324E-565A-4A26-9ED5-5C638FA964E3}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{EE0FF7D8-C160-4203-91ED-73706E508332}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Windows IP Configuration

An error occurred while renewing interface Ethernet : unable to contact your DHCP server. Request has timed out.

before the network device reset i also did these reset commands. it's probably irrelevant but it might not be because they say a os restart is required to complete it. which might mean a network device restart

netsh interface ip reset
Resetting Global, OK!
Resetting Interface, OK!
Resetting Unicast Address, OK!
Resetting Neighbor, OK!
Resetting Path, OK!
Resetting , failed.
Access is denied.

Resetting , OK!
Restart the computer to complete this action.

netsh winsock reset catalog
You must restart the computer in order to complete the reset.

i also disabled VMware Bridge Protocol for the network connection associated with the device, which is probably irrelevant

system

my system is

Operating System
    Windows 8.1 Enterprise 64-bit
Motherboard
    ASUSTeK COMPUTER INC. P8Z77-M PRO (LGA1155) 30 °C

devcon driverfiles "PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09"
PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09\4&21A1C3AE&0&00E5
    Name: Realtek PCIe GBE Family Controller
    Driver installed from C:\WINDOWS\INF\oem30.inf [RTL8168FB.ndi]. 5 file(s) used by driver:
        C:\WINDOWS\system32\DRIVERS\au630x64.sys
        C:\WINDOWS\system32\RtNicProp64.dll
        C:\Program Files\ASUS\AMDA\U3\U3.dll
        C:\Program Files\ASUS\AMDA\U3\U3BoostSvr64.dll
        C:\Program Files\ASUS\AMDA\U3\U3BoostSvr64.exe.manifest
1 matching device(s) found.

devcon drivernodes "PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09"
PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09\4&21A1C3AE&0&00E5
    Name: Realtek PCIe GBE Family Controller
Driver node #0:
    Inf file is C:\WINDOWS\INF\oem30.inf
    Inf section is RTL8168FB.ndi
    Driver description is Realtek PCIe GBE Family Controller
    Manufacturer name is Realtek
    Provider name is Realtek
    Driver date is 2013-03-14
    Driver version is 8.13.314.2013
    Driver node rank is 16719872
    Driver node flags are 0000B045
        Inf is digitally signed
Driver node #1:
    Inf file is C:\WINDOWS\INF\oem30.inf
    Inf section is RTL8168FB.ndi
    Driver description is Realtek PCIe GBE Family Controller
    Manufacturer name is Realtek
    Provider name is Realtek
    Driver date is 2013-03-14
    Driver version is 8.13.314.2013
    Driver node rank is 16711680
    Driver node flags are 0004B045
        Inf is digitally signed
Driver node #2:
    Inf file is C:\WINDOWS\INF\oem81.inf
    Inf section is RTL8168FB.ndi
    Driver description is Realtek PCIe GBE Family Controller
    Manufacturer name is Realtek
    Provider name is Realtek
    Driver date is 2012-02-03
    Driver version is 7.52.203.2012
    Driver node rank is 16719872
    Driver node flags are 00003045
        Inf is digitally signed
Driver node #3:
    Inf file is C:\WINDOWS\INF\netrt630x64.inf
    Inf section is RTL8168FB.ndi
    Driver description is Realtek PCIe GBE Family Controller
    Manufacturer name is Realtek
    Provider name is Microsoft
    Driver date is 2013-05-10
    Driver version is 8.1.510.2013
    Driver node rank is 16719872
    Driver node flags are 00102045
        Inf is digitally signed
1 matching device(s) found.

after uninstalling the realtek network driver windows revert to this driver which doesnt have a wake problem

C:\Users\User>devcon driverfiles "PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09"
PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09\4&21A1C3AE&0&00E5
    Name: Realtek PCIe GBE Family Controller
    Driver installed from C:\WINDOWS\INF\netrt630x64.inf [RTL8168FB.ndi]. 1 file(s) used by driver:
        C:\WINDOWS\system32\DRIVERS\Rt630x64.sys
1 matching device(s) found.

C:\Users\User>devcon drivernodes "PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09"
PCI\VEN_10EC&DEV_8168&SUBSYS_85051043&REV_09\4&21A1C3AE&0&00E5
    Name: Realtek PCIe GBE Family Controller
Driver node #0:
    Inf file is C:\WINDOWS\INF\oem81.inf
    Inf section is RTL8168FB.ndi
    Driver description is Realtek PCIe GBE Family Controller
    Manufacturer name is Realtek
    Provider name is Realtek
    Driver date is 2012-02-03
    Driver version is 7.52.203.2012
    Driver node rank is 16719872
    Driver node flags are 00002045
        Inf is digitally signed
Driver node #1:
    Inf file is C:\WINDOWS\INF\netrt630x64.inf
    Inf section is RTL8168FB.ndi
    Driver description is Realtek PCIe GBE Family Controller
    Manufacturer name is Realtek
    Provider name is Microsoft
    Driver date is 2013-05-10
    Driver version is 8.1.510.2013
    Driver node rank is 16719872
    Driver node flags are 00142045
        Inf is digitally signed
1 matching device(s) found.
share|improve this answer

Open CMD and try this command to clear DNS cache: ipconfig /flushdns after that, run test ping to google.com:ping google.com. If this work you should ping success to google.com. Hope this helpful!

share|improve this answer
    
Welcome to Super User! This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  DavidPostill Apr 6 at 10:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.