Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have created a Linux kernel and for some reason an extra drive is always added at bootup.

My hard drive is listed as /dev/sdb. /dev/sda is created too, and it is 8 MB in size. I can't find anything in the kernel config that is creating this, but if I use a different kernel it is not there. Kernel logs show it as an attached SCSI device, looks just like my hard drive but only 8 MB, and has no partition table. It also doesn't appear to be a physical device. I've tried the kernel on many different models of PCs and it is always there.

Does anyone know how to remove it?

/dev/disk/by-id gives me:


hdparm -i /dev/sda gives me an "invalid argument".

dd if=/dev/sda of=sda.img the resulting file does not have any content

sdparm results:

/dev/sda: Linux     scsi_debug        0004 Device identification VPD page:   Addressed logical unit:
designator type: T10 vendor identification,  code set: ASCII
  vendor id: Linux   
  vendor specific: scsi_debug      2000
designator type: NAA,  code set: Binary
  0x53333330000007d0   Target port:
designator type: Relative target port,  code set: Binary
 transport: Serial Attached SCSI (SAS)
  Relative target port: 0x1
designator type: NAA,  code set: Binary
 transport: Serial Attached SCSI (SAS)
designator type: Target port group,  code set: Binary
 transport: Serial Attached SCSI (SAS)
  Target port group: 0x100   Target device that contains addressed lu:
designator type: NAA,  code set: Binary
 transport: Serial Attached SCSI (SAS)
designator type: SCSI name string,  code set: UTF-8
 transport: Serial Attached SCSI (SAS)
  SCSI name string:
share|improve this question

migrated from Apr 12 '12 at 13:56

This question came from our site for professional and enthusiast programmers.

What happens if you dd if=/dev/sda of=sda.img? Does the resulting sda.img file have any content? – Renan Apr 12 '12 at 15:53
If it is not an ATA device, hdparm naturally fails. You should use sdparm -i /dev/sda for block devices using the SCSI layer. – jørgensen Apr 12 '12 at 15:53

1 Answer 1

up vote 2 down vote accepted

Perhaps you enabled a SCSI debug device while you were creating your kernel?

share|improve this answer
Thanks for everyone's help. This was the problem. – user1279156 Apr 12 '12 at 17:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.