Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was scanning a bunch of papers and had scanned several of them when it happened. The SimpleScan program that I used just died (the window disappeared). The scanner stopped it the middle of the process and won't go back anymore. It's a CanoScan LiDE 110 that doesn't seem to have any kind of a reset button and is only connected to a USB port. I tried to disconnect it and plug back in, with no apparent result. What could I try?

The following lines in my syslog show what happened when SimpleScan crashed and when I plugged the scanner out and in again:

Apr 13 00:08:59 lev-home kernel: [ 9469.334871] simple-scan[3518]: segfault at 18 ip 0000000000415a8a sp 00007fff2fcbaef0 error 6 in simple-scan[400000+3c000]
Apr 13 00:09:47 lev-home kernel: [ 9518.072097] usb 1-6: usbfs: USBDEVFS_CONTROL failed cmd simple-scan rqt 64 rq 4 len 8 ret -110
Apr 13 00:10:05 lev-home kernel: [ 9536.000249] usb 1-6: USB disconnect, device number 6
Apr 13 00:10:05 lev-home kernel: [ 9536.001569] usb 1-6: usbfs: USBDEVFS_CONTROL failed cmd simple-scan rqt 64 rq 4 len 2 ret -108
Apr 13 00:10:12 lev-home kernel: [ 9542.292029] usb 1-6: new high speed USB device number 7 using ehci_hcd
Apr 13 00:10:12 lev-home mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-6"
Apr 13 00:10:12 lev-home mtp-probe: bus: 1, device: 7 was not an MTP device
share|improve this question

1 Answer 1

up vote 1 down vote accepted

You might want to try and disconnect the USB cable from the computer and unplug the power from the scanner. Then reboot the computer, reconnect the USB cable to the computer and power up the scanner.

share|improve this answer
    
I mentioned that I tried disconnecting the USB cable and that the scanner didn't have a power source apart from that. –  Lev Levitsky Apr 12 '12 at 21:24
    
Have you tried to reboot the computer? This has worked for me a few time to get a scanner to work again. –  Jeff Chilton Apr 12 '12 at 21:25
    
Haha, somehow it went back on when I opened SimpleScan and pressed the "Scan" button. That's strange that it only helped after the reboot, because the syslog showed the same not an MTP device message, so I thought nothing changed. Thanks :) –  Lev Levitsky Apr 12 '12 at 21:30
    
From the log it appears that the software is not able to talk to the scanner. Have you tried to connect the scanner to a different USB port? –  Jeff Chilton Apr 12 '12 at 21:31
    
Yes I have. Like I said, it's surprising that it worked after the reboot despite that message. –  Lev Levitsky Apr 12 '12 at 21:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.