Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am loading a webpage from a host behind a cellular modem. The web port is routed correctly and the page starts to load (title loads and part of the html head), but then always stops when trying to load a js file in the webpage. It is very consistent where it stops.

The host computer worked fine before it was behind the modem.

I do not have physical access to the host or modem.

Without having yet been able to access the modem configuration (it is a clients modem), I have a hunch that the modem may have a setting that is causing it to block the webpage request based on some criteria about the content of the page. Is this possible? If so, what settings should I look for when I go into the config?

There is also a

TELUS Smart Hub HSPA WiFi Router with Voice

between the host computers and the outside world. SO it may something with that device.

There are actually four computers behind the modem, ports 81 to 84 are mapped to their respective webservers. They all behave the same.

*update

I have confirmed that the issue is that a js file called checkAXversion.js is getting blocked. The js file has the string "ActiveX" in it, which may cause the modem to block the file due to an errant activex blocking filter. Through the modem interface I have double checked that the filter is turned off. Next thing to do is upgrade the modem firmware and see if that fixes the problem.

share|improve this question
1  
Is it possible that the js is hardcoded with a url? eg, if the js was loaded using http://thewebserver.com/scripts/script.js rather than just /scripts/script.js then it would attempt to use port 80, rather than the correct port you have forwarded and accessing the rest of the content with –  Paul Apr 13 '12 at 0:05
    
The other thing you can try is just loading the js file itself by putting its url in your browser. –  Paul Apr 13 '12 at 0:06
    
The specific js file cannot be accessed direclty, though all the previous ones can. So its definitely blocking on the bad js file. –  michael Apr 13 '12 at 0:33
    
the path to the bad js file is relative in the html file like the others (/activex/checkAxVersion.js) –  michael Apr 13 '12 at 0:34
add comment

1 Answer

Without knowing the modem model it is difficult to definitely identify what is blocking the .js files, however, most routers have content filtering options.

The Telus (see page 36) definitely has the option, but the default is to not block anything, and it would have to be pretty intentional to block it with the options available. Your javascript references activex, so perhaps the "block activex" option would be enough to stop the entire js script loading.

Different routers have different levels of content filtering available, and usually under a content filtering heading in the options. It should be fairly similar to the Telus options in the linked pdf.

share|improve this answer
    
hmmm good idea. The filtering was not on, but as soon as I read your answer I was hoping it was! I wonder if the js file not being served is referencing something else via an absolute path... –  michael Apr 13 '12 at 4:17
    
The server on the hosts is lighttpd –  michael Apr 13 '12 at 4:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.