Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use GNU Emacs to write small programs. I use the compile command make -k but i always get the message

make -k 
'make' is not recognized as an internal or external command,
operable program or batch file.

I've tried installing MinGW and modifying the path of my environment variables and a lot of other things but it does not work.

share|improve this question
    
Since you talk about MinGW I assume you are on MS windows. Its not easy to compile emacs on windows(atleast for a beginner). Its better to use precomipiled binaries. you can get it here. go to the end of the page to get latest version –  kindahero Apr 13 '12 at 5:33
4  
After you change the environment variable PATH to include the 'c:\path\to\mingw\bin' which includes the 'make' program, restart emacs and give it another go. Also. You could evaluate `(setenv "PATH" (concat "c:\path\to\mingw\bin;" (getenv "PATH")))' from the scratch to remove the need to restart emacs. If this comment solves your problem I will turn it into an answer. –  kjfletch Apr 13 '12 at 6:45
add comment

1 Answer

First verify that you a DOS window can find the make command. This will verify if it is in your PATH environment variable and also installed.

Then, once you know that it is working but still not working from inside of emacs check the values of PATH that emacs is seeing by evaluating (getenv "PATH") in the scratch buffer or via M-:. Also check the value of the exec-path variable.

Any problems with any of the above could cause your problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.