Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am in trouble deep, since after the the upgrade I cannot run any Java Application. In particular some of the most known Java IDE: Eclipse Indigo or IntelliJ 10.

I am trying to interpret the error details, but there's a lot of things and I don't know how to get trough. By running Eclipse from console I get this:

Invalid memory access of location 0x30469bfa8 rip=0x1040dd43b Segmentation fault: 11

and even when I am able to start, I cannot do anything, all the Eclipse panes show errors, mostly null pointer ones.

Has anyone encountered this ? I have played a bit with the Java preference pane with no success at all.

Update: After a shutdown (not a restart) everything started working again, but few minutes later same problem again on all Java IDE.

Seems that Apple has solved the correct .dmg download, so I downloaded the update and installed manually, but things are still not working.

By the way, are there any other way to downgrade to latest 002 ?

[EDIT at 27/08/2012]

This problem has gone apparently by itself, I didn't do anything in particular other than following all the upgrade seed by Apple for Lion, all the suggestions pointed out in comments didn't solve the issue. Don't know the policy of 'Superuser' web site, but as I cannot replicate or state a proper way of solving the problem, if you want this question could be closed, or deleted.

share|improve this question

migrated from stackoverflow.com Apr 13 '12 at 13:01

This question came from our site for professional and enthusiast programmers.

    
Did you try to manual download and reinstall the update? –  Carlo Apr 13 '12 at 8:31
    
uhm...no should I ? Did you get a similar problem ? –  Leonardo Apr 13 '12 at 8:34
    
Luckily no, I've just did the update, but I would give it a try. –  Carlo Apr 13 '12 at 8:38
    
This is the link: support.apple.com/downloads/DL1515/en_US/JavaForOSX.dmg but maybe the localization is not the one you want. –  Carlo Apr 13 '12 at 8:55
    
And if you had the Flashback trojan? Check this out. –  Carlo Apr 13 '12 at 9:35

1 Answer 1

Java Preferences - Enable applet plug-in and Web Start applications.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.