Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Asus laptop with a Realtek PCIe GBE Family Controller wired network adapter using Windows 7. It takes 2 hours to copy a 3 gig file over the LAN. (Using the wireless connection is faster at 25 min). I get the same result if I boot to Ubuntu so it is not the OS. Other computers using Windows XP the copy finishes in minutes. It is not the cables. I have downloaded the latest driver.

Here are the control panel advanced settings, the settings are default.

Auto disable Gigabit
Energy efficient ethernet
Green Ethernet
IPv4 Checksum Offload
receive buffers
Shutdown Wake on LAN
Speed and duplex
TCP Checksum offload (IPv4)
TCP Checksum offload (IPv6)
Transmit buffers
UDP Checksum offload (IPv4)
UDP Checksum offload (IPv6)
Wake on Magic Packet
Wake on Pattern Match
WOL & Shutdown Link Speed

I got access to a network with a win 2003 server and was able to copy files at high speeds with my laptop - so the problem is NOT with my network card at all.

The computer I was trying to copy to on my network is running Windows XP. Other computers on my network running Windows XP can copy OK to each other.

So the new question is: Is there some problem with Windows 7 or Ubuntu copying to Windows XP that would slow down the process drastically?

share|improve this question
    
Are you sure the problem isn't with your wired cables? A bend on a cable, or some phisical fault on a cable should cause a lot of packet loss... –  Diogo Apr 13 '12 at 17:54
    
no, same result with different cables, router port –  wayne-h Apr 13 '12 at 18:20
    
If it is possible, try swapping the NIC card with that of another computer to see if it is really the NIC card. –  Tom Wijsman Apr 13 '12 at 18:31
    
this is a laptop so not possible –  wayne-h Apr 13 '12 at 18:43

1 Answer 1

I have disconnected the router from the internet, then disabled firewall and ms security essentials on the XP machine. After that, copy speed was restored. However, after I turned firewall & mse back on & connected to internet it is still working ok. So, problem is fixed but not sure why...

share|improve this answer
    
Glad that you have resolved the problem. I thought you were providing extra information as an answer again, sorry... –  Tom Wijsman Apr 17 '12 at 19:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.